Report
5 years, 1 month ago.

problem with New Nucleo F401re

I am new to this board and mbed but not micros in general as I have been programming them for like 39 years.

I got a Nucleo and converted my VNA code that talks to a DDS board and some analog logic. All was working fine.

All of a sudden, the nucleo wouldn't take code. I couldn't copy over to it as it reported it had 4k and 20k was required for even the simplest program.

So I ran disk repair on my mac and after a bunch of screwing around, it started to report like 512k available and would take code. The DDS initialization code runs as I can see it on the scope. I can't blink any LEDs on the board and cant communicate with it over the VCP (which worked fine before).

I tried flashing the new firmware and at least it isn't dropping connection now when I load code but other than that, I can't communicate with it. I tried two different terminal emulators as well as my custom PC application.

Any ideas? Bad board? I find that hard to believe as I've never had a blown board and must have 10 or so on my desk piled up.

Thanks, cool site.

Jerry

Добрый день. Подскажите, не могли бы вы быть столь добры и купить, для меня http://www.st.com/web/catalog/tools/FM116/SC959/SS1532/LN1847/PF260320 . Сколько бы вы взяли за доставку в Россию + стоимость платы + ваша помощь?

У нас в России, их еще нет, а F401 редкость и стоят 42$ и это дорого =(

Good afternoon. Prompt, could you be so kind and buy for me http://www.st.com/web/catalog/tools/FM116/SC959/SS1532/LN1847/PF260320 . How much would you take for the shipping to Russia + postage fee + your help?

Here in Russia, they do not exist, and F401 rarity and cost $ 42 and it is expensive = (

posted by Sergey Kordubin 10 Jul 2014
Comment on this question

3 Answers

5 years, 1 month ago.

Hello Jerry,

I have seen this problem reported by you in other 2 different threads where I replied as well.. There can be an interface issue which you faced.. Might help if you share your example, provide more details which OS you are running. Somebody can run it with the same configuration and the same application to see if it can be made broken or not.

As I noted previously, can you run any IDE or at least console to fully erase the chip? I have already experienced some problems with interfaces on other boards... I usually just connected the external tool or used external software to communicate to the chip and do full erase/recovery. Does openOCD support nucleo board? That could help you..

Regards,
0xc0170

I am giving up on this board. It worked perfectly until I flashed it (by copying a file over) about the 15th time.

If I plug it into windows XP and eject it once, I can then see more than 28k, actually the entire storage of roughly 512k or so. After I do this though, now no programs will run. I tried just the simple LED pulse tests, etc. Prior to this, the only problem I had was that the VCP wasn't working though the board was running as it initialized the downstream device. The VCP worked fine for the first 15 passes of code as I converted it from AVR.

The problem developed on Windows 7. I then move it to my MAC running Mavericks and was able to erase it. Even then the VCP never worked again. Then I put it on XP and I can get around the 28k 'full' problem but all the code that worked before gives me a ' bad extension file' or 'swd error'.

So I am giving up. I have two of the discovery boards coming and if they go the same way, I will move this project back the the AVR chips.

I had high hopes for the STF4 but how can they release a board like this? I am not the only one with this problem. And to be so cocky to put it in the Arduino form factor? What are they thinking, sell it in Radioshack? If the arduino guys start buying these they will run STM out of the country as those users aren't as tolerant and expect more turn-key than I do.

Thanks for the response. It might have been a driver problem? Or maybe it got corrupted by rebooting when the code loaded.

posted by Jerry Hancock 30 Jun 2014
5 years, 1 month ago.

Hi,

Make sure you have the latest ST-Link firmware programmed on your board.

You can find it here: http://mbed.org/teams/ST/wiki/Nucleo-Firmware

Regards.

Just to close this out, in my case, the board ended-up having a blown processor chip. Compared to the new boards I have, the processor chip was really hot.

posted by Jerry Hancock 09 Jul 2014
5 years, 1 month ago.

https://mbed.org/questions/3996/Nucleo-F401RE-SWD-ERROR-problem/#answer4513

I think it would be worthwhile to refer to the Datasheet for the micro controller STlink, perhaps the point is h the flash perceives only 20Kb? And receiving binary code it already it sews in STM32F4? I am also a newbie and I think that it is worth flash large files via some other method. Russian Hi =)

Look at the specification STM32F103TSB there is just a 20-KB SRAM, I understand more than the RAM memory on the controller "On-board ST-LINK/V2.1", you can not pour firmware by "Mass storage (USB Disk drive) for drag'n'drop programming"

Я думаю стоит обратиться к даташиту на микро контролер STlink, возможно все дело в том ч то ее флеш воспринимает только 20Kb? И получив бинарный код она уже его зашивает в STM32F4? Я тоже новичок и мне кажется что стоит прошивать большие файлы через другой способ. Русским Привет =)

Посмотрите на спецификацию STM32F103RB там как раз 20-КБ SRAM, Как я понял, больше чем ОЗУ память на контролере "On-board ST-LINK/V2.1", вы не сможете залить прошивку методом "Mass storage (USB Disk drive) for drag'n'drop programming"

Just to close this out, in my case, the board ended-up having a blown processor chip. Compared to the new boards I have, the processor chip was really hot. posted by Jerry Hancock 09 Jul 2014

-this was right, mine as well. (nucleo-F103RB)

posted by Thomas Carter 20 Dec 2014

You need to log in to post a question