5 years, 5 months ago.

while using rpc interface library i get rpc.h not found. where can i find the libraries?

Error: Cannot open source input file "rpc.h": No such file or directory in "RPCInterface/RPCFunction.h", Line: 34, Col: 17

Question relating to:

Did you import RPC library to your project? Which example did you follow?

posted by Martin Kojtal 17 Jun 2014

hi Martin, i imported the RPCInterface library ( http://mbed.org/cookbook/RPC-Interface-Library ). i followed the serial example given there. compiling it gives the above said error. i tried importing the mbed-rpc library which gave the following error: Error: Identifier "parse_pins" is undefined in "mbed-rpc/Arguments.cpp", Line: 79, Col: 12

posted by bhavik gala 17 Jun 2014

I have the same Problem... I imported the RPC-Interface-Library from this page and get the same error as bhavik gala. Also the mbed-rpc Library isn't working because there are .h's missing.

Did someone figure out where the missing rpc.h is?

posted by Florian B 16 Feb 2015

Hi Florian, you can refer the following answers for:

http://developer.mbed.org/questions/3827/where-to-import-a-working-rpch-and-relat/

http://developer.mbed.org/questions/3897/AnalogIn-not-working-in-rpc/

it worked for me. let me know if works for you as well... Regards, Bhavik N Gala

posted by bhavik gala 25 Feb 2015
Comment on this question

1 Answer

4 years, 9 months ago.

Hello!

If you import this program: http://developer.mbed.org/users/MichaelW/code/RPC_Serial/ And use Revision 1. (You can click on Revision on the top bar of your compiler, chose Revision 1 and than click switch) The RPC Interface Library still works.

In the new mbed-rpc library there is already an existing header for a Custom RPC function (Didn't use it though because I need to use Matlab, and the Matlab library only works with the old versions).

Hope this could be of help for somebody with a similiar Problem.

Note: I'm not the one who figured this out. The one who helped me out here was the User Andy A.

Best Regards


You need to log in to post a question