5 years, 6 months ago.

LPC800-MAX "disk full" error

Hi,

I've been using a LPC800-MAX for a while now on different OS X machines. Now I'm running into the following problem: When I try to copy new .bin files onto my MBED drive, the OS complains about insufficient space on the disk and the disk gets ejected. I've tried all the usual tricks including deleting .Trashes etc from the MBED disk from the command line, but while the disk is being displayed as "empty" using ls -al before I unmount it, those files magically reappear after reconnect. I also tried formatting the MBED disk from both the Diskutil GUI as well as diskutil on the command line, but half way through the process both quit with a generic "format failed" (no error code!) and I'm back at the beginning. I booted into CRP mode and updated my firmware, but that didn't help either.

Any hints?

Boris

Comment on this question

2 Answers

5 years, 6 months ago.

Hey Boris,

I've found with a Mac that even when you trash files, you need to either:

  • Go to Trash and Empty Trash; or
  • Cmd+Shift+Delete to empt trash.

However, you tried to format and that returned fail, so I doubt emptying the Trash properly would help. Have you tried plugging your LPC800-MAX into a Windows machine? Again, everytime my Mac breaks my partition, I plug it into my Windows machine and let it fix it.

One last resort is to power off the board, hold reset, then plug the board into ur Mac/Windows machine.

Asides that, I'm sorry I have no other solutions. I have an LPC812-MAX and it has never misbehaved :(

Good luck and do let us know if you find a fix.

Ian :D

So I plugged it into a Windows machine. Same thing. MBED mounts. I can see 260+ kb free. But when I try copying files, I get a "disk full" error and it's refusing to format that disk. I'm not sure how, but it seems I killed my memory.

posted by Boris Adryan 23 May 2014
5 years, 6 months ago.

Hi!

Silly question but How big is your .bin-File? LPC-800MAX has only 16MB Flash.

Maybe its to big for the LPC-800MAX.

Charly

It's the 7kb "Hello World". :-(

posted by Boris Adryan 21 May 2014

You need to log in to post a question