Report
5 years, 1 month ago.

Can not connect to wifi ? Failed to update file ?

Followed instruction up to set wlan ssid and password but failed at join ? Also failed at ftp update? This is brand new device and not working? Need help, thanks

Question relating to:

Comment on this question

3 Answers

4 years, 8 months ago.

I have a similar problem. ver 4.41. RN171 I can not connect using net password

Starting from the factory reset I put the SSID name for one net without key or authentication. The module RN171 connects Ok and the DHCP assign an IP. Bidirectional communication is properly well.

Then I decide to use a key or a wep 64 authentication in the same net. I put the auth key in wlan phrase, 5 char. The same char as in the wireless net.

The RN171 just connects but no IP address is assigned.

I try with another net and diffrent keys but the same.problem.

I can connects with a password network.

Then I decided to use a static IP address instead of having one assigned via DHCP, I first turn off DHCP and then I set the IP address I like.

set ip dhcp 0 set ip address 192.168.0.100

Impossible communicate with the RN171 I get always the message Associate! But I can not transfer data.

Any idea? Thank you.

I don't have the same configuration as you, I use WPA for security. If others can't replicate your scenario, this might be a situation where you want to try to do all of this using WiflyConfigure, then copy the transactions and file the log with Microchip. This link lets you access microchip forums, and access a support system.

posted by David Smart 03 Oct 2014
5 years ago.

Hi,

I have the same problem. when I write "ftp update" the system give me the number 0.0.0.0 . When I'm using this number that look like an IP the system send me a error message.

Thank you and sorry if this is a stupid doubt,

5 years, 1 month ago.

Hi quan, I guess if it failed to join, then it could not reach home for an ftp update, so let's focus on the join problem.

The Components - WiFly is certainly one key resource, and perhaps that's where you posted this question from. Perhaps even more important, at this stage of your troubleshooting, is the Cookbook - WiFly page, which has a number of communication examples.

On the cookbook page, perhaps half-way down, is a section "More Details", a "Wifly_configure" program and details for using it. This may be the most valuable to ensure that you have the right connections and settings for your interface to the WiFly module. If you follow along in that section, what response do you get from the module?

hi I followed the instruction at page Components - WiFly and also read the Cookbook - WiFly page. When send join command, i responded connecting to 0.0.0.0 I thing not success of join, should connected to an IP address. When I sent an "ftp update" command, it responded update failed. I tried ten times as below instruction but all failed. My friends has the same problem with this device --------------

power cycle the device send $$$ send factory RESET send scan send set wlan ssid network_name send set wlan phrase password send join send ftp update send boot image _ _ (the number of file returned from ftp update) send factory R power cycle the board

posted by quan hu 14 May 2014

OK, so let's see what we know -

  • your rx and tx pins are connected and you can communicate.
  • it does not join your access point.

This opens new questions -

  • does it see your access point?
    • Have you tried "scan" and see what it finds?
    • Is your AP the strongest one it sees?
    • How many APs are all on the same channel as yours, and do they have a strong signal?
  • is the security not set right for your AP?
    • is your API broadcasting the SSID?
    • can you reduce / disable the security on your API? [I know I would not normally want to, but as a test, perhaps it is necessary]
    • perhaps you have MAC filtering on, or some other configuration that the driver is not matched to?
  • do you have a good power supply?
    • I don't know what the current requirements are (in the data sheet I'm sure), but modules normally take a lot more power to transmit than to receive.
    • do you have a good strong and well regulated power supply?
    • do you ever see the reboot message come out spontaneously?
posted by David Smart 15 May 2014

To post an answer, please log in.