9 years ago.

USB Device on KL25Z

Hello, everyone Recently I bought a Freescale FRDM-KL25Z and I made all the necessary changes to use it with mbed and now I can use it as desired. I connect it through the SDA port and it's recognized as a flash drive. My problem is that I can't use the USB port. I tried Airmouse and the USBSerial_HelloWorld. When I connect the USBKL25Z port to my USB, my windows 8 shows the message that says that the device was not recognized and it's shown as an unknow device inside the control panel. (Sorry, the messages are in Portuguese) /media/uploads/farinhaki/controlpanel_message.png /media/uploads/farinhaki/tray_message.png

How can I solve this problem? Could my board be damaged?


2 Answers

9 years ago.

Try using the USBMouse for example, this does not require special drivers (Do FTDI drivers really work for this? There are USBSerial drivers here on the USBSerial page, I wouldn't expect FTDI drivers to be compatible).

If USBMouse also doesn't work, try it with a USB hub in between. All my freescale devices do not work on my laptop with the mbed stack (with another usb stack it does work, but NXP devices do work with the same mbed stack, I haven't been able to figure out what the issue is), although this really seems to be a special situation. With a USB hub in between it does work for me.

Accepted Answer

Erik, I have seen the same thing - works via a hub but not "straight up". Any suggestions on where to start looking?

posted by Cpu Talk 07 May 2014

Sadly not a clue. I really think we need someone with more knowledge of USB standards (and probably hardware) than I have. I have tried with logs on both my laptop and the mbed to try to find out what goes wrong, but didn't succeed. With code using another USB stack it did work, so it is not the hardware. Aditionally the K20 interface IC does work fine for me, and that has the same USB peripheral.

So USB stack on NXP works for me, on Freescale doesnt. Other USB stack on freescale does also work. The interface IC USB stack also works. I have looked at the device specific parts of interface USB stack vs regular USB stack, and they seem to be fairly similar. Which makes me think it is in the stack itself, but then why does it work with an LPC1768/LPC11u24?

I have given it several tries, but haven't been able to find out the issue, let alone solve it. This is btw on an Asus N56. (Which btw also doesn't accept a very old usb flash drive of mine, so it is apparantly a combination of the the KL25 and my laptop).

If anyone else can figure out more I'd be very happy, but for me it is currently somewhere in the fridge: not looking at it further (not in the least because I expired the trial licenses for several USB loggers :P).

posted by Erik - 07 May 2014

Thank you, Erik. It worked connected through a usb hub. I'd like it working without this hub, but it's ok for now.

posted by Ricardo Farinhaki 07 May 2014
9 years ago.

Just to rule out the obvious, did you install an FTDI driver? See this link: http://www.ftdichip.com/Drivers/VCP.htm

Aaron, are you sure FTDI drivers work on the mbed USBSerial?

posted by Erik - 07 May 2014

On my Mac, I seem to recall that I had some issues - even after the initial prep on a Windows machine - until I added some drivers. It's been a few years, so I could be "mis-remembering" things.

posted by Aaron Minner 07 May 2014

The FTDI drivers probably aren't appropriate for the MBED USBSerial; they're tied to specific VID/PID combinations that don't match the VID/PID of the mbed. Aren't there specific Windows serial drivers that match the mbed?

posted by Ned Konz 08 May 2014