5 years, 9 months ago.

Connecting the C027

Hi,

two questions: 1) Do I need to connect power to the 7-17v DC in order to save my *.bin file and run it? 2) Is there a more detailed manual on C027, i.e. what is the meaning of the individual LED's?

Background: When copy/pasting the file C027_HelloWorld_LPC1768.bin to the mounted USB folder (on a Mac), the mounted disk is ejected. On next mount I see a file "fail.txt" with Content "SWD ERROR". There are a few other posts on mbed.org with this error, all unanswered AFAIK.

Thanks,

  • Stefan

Question relating to:

The u-blox-C027 is a complete starter kit that allows quick prototyping of a variety of applications for the Internet of Things. The application board has a MAX-M8Q GPS/GNSS receiver and ...
Comment on this question

3 Answers

5 years, 9 months ago.

Yes you need to supply 7-17V DC power to the VIN. You can use either the barrel jack or the input on pin header.

The LEDs have the following meaning:

  • DPWR USB cable plugged in USB B connector
  • UART CDC serial port activity
  • MSD Drag and drop programming activity
  • HID CMSIS-DAP debug interface activity
  • NET_IND Modem network indicator
  • RI Modem ring indicator
  • TPLS Indicates GNSS is synchronized with GPS or UTC time grid
  • LED1 User / Error LED (only on REVB board)

OK - now on my 3rd PSU. 10v DC @ 1.2amps...

Still the same behaviour ... :-)

Now with an even more powerfull PSU. I'm now using a Philips PSU for a monitor. This device is rated at 16v DC at 3.95 amps.

It still does the same thing!

Has anyone got this working with an external plug-in power supply??? :-( :-( :-(

Kind regards, Nicholas

posted by Nicholas Herriot 13 Feb 2014
5 years, 7 months ago.

Well you have better luck than me!

I've updated the firmware on both mine. Both now refuse to work on Linux Mint 13.

I can't even see them as mass storage devices.

Did you update the firmware on yours?

Kind regards, Nicholas.

To anyone finding difficulties when using Linux. Some things I've found out while using the board that may save people hours of time!

  1. You need a power supply in the power jack preferably over 1000milliamps.
  2. When you copy a binary file the device DOES NOT behave like the mbed, you can't see the bin file when it restarts and appears as a mass storage device. The user LED looks like it's low on power, same as when you attach or pull too much power from an mbed (e.g. you plug in a dongle to the mbed).
  3. If you are using a USB 3.0 port and a Linux distro with a kernel less than 3.4 you might get problems. You can check this by doing /> uname -a on linux to see what you are running. If you run />dmesg from a command line you will see the USB errors.

See my discussion points on how to get your USB 3.0 port on Linux working again.

Kind regards, Nicholas.

posted by Nicholas Herriot 19 Feb 2014
5 years, 9 months ago.

Michael,

thanks a lot for your fast answer. Will find a power supply and then try again!

BR,

Hi Michael and Stefan,

how are you getting on? I've now tried: 1) a PSU from XP Power that delivers 12v DC and 1.66Amps 2) a PSU from Connect-It. This can be set to 12, 9, 6 and 3 v DC. It delivers 6VA (watts).

As soon as I try and flash (copy the binary) to the C027 the lights on the device dim, and it then dissapears on the USB bus, after a few seconds it re-appears as mass storage deivce with flickering LED's.

What kind of power supply do I need for this thing? Anyone else had this problem? If so what power supply did they use? ... :-(

Kind regards, Nicholas.

posted by Nicholas Herriot 13 Feb 2014

Hi, we have normal 9V, 1A PSU, which has not caused problems so far.

We were not able to get it working with MacOS, so only under Windows,

posted by Stefan Vaillant 13 Feb 2014