8 years ago.

Windows 8.1 and KL25Z

Mbed Guys, When will there be a fix for the problems associated with win8.1

Dave.

Question relating to:

Hello Dave,

the bootloader has to be fixed by PEmicro. There was a fix for msd (mbed interface), and one user confirmed that connecting/disconnecting stopped.

I'll build the newest CMSIS-DAP for all supported freedom platforms today and share it on my blog. I'll drop a line here, once it gets published.

Regards,
0xc0170

posted by Martin Kojtal 04 Dec 2013

Dave, please can you test it, eventhough does not solve a problem with a bootloader. Still have to flash the CMSIS-DAP interface on the machine which works (not 8.1).

http://mbed.org/users/Kojto/notebook/cmsis-dap-for-the-freedom-platform-kl05-kl25-kl46-/

posted by Martin Kojtal 04 Dec 2013

Martin, I have now checked your update. I used win7 to update my KL25Z, then plugged it into my win8.1 box. After a short delay all the drivers loaded, and I could see the mbed as a Drive. It also ran the pre-loaded program. I compiled a quick blinky prog and did a drag and drop on to the KL25Z, which then ran with no problems, I then re-compiled the original program dragged and dropped, again the prog ran without problems. Well done! I can now use my KL25Z on my win8.1 box.

Dave.

posted by David Fletcher 04 Dec 2013

This is the solution:

http://www.pemicro.com/opensda/faqs/faqs.cfm

http://www.pemicro.com/opensda/index.cfm You have to register and download OpenSDA Firmware (MSD & Debug) Firmware Apps (.zip file) and read BOOTUPDATEAPP_release_notes.txt

OpenSDA Frequently Asked Questions

Issue: Bootloader versions 1.10 and earlier are not allowing firmware update and MSD FLASH programming on my OpenSDA board, with the Linux, MacOS or Windows 8/8.1 operating systems.

Solution: Support for Windows 8/8.1, MacOS and Linux operating systems was added to Bootloader version 1.11 and MSD firmware version 1.14. Please make sure that your board is programmed with Bootloader version 1.11 or higher prior to attempting to update your OpenSDA board with a new firmware application. Important: If you are currently running Bootloader version 1.10 or earlier, you will need to find a Windows XP or Windows 7 PC to perform this update.

Please follow these steps to find out what version of Bootloader your board is programmed with: Start your board in Bootloader mode by holding down the RESET button prior to plugging it into USB port. Open the SDA_INFO.HTM file, which will contain version numbers of Bootloader as well name and version of current OpenSDA firmware you are using. If your board is not running Bootloader version 1.11 or higher, please download the latest OpenSDA Firmware Apps from P&E website and follow instructions in corresponding documentation to update the Bootloader using the BOOTUPDATEAPP_Pemicro_v111.SDA application. Once the Bootloader is updated via BOOTUPDATEAPP, the OpenSDA board can then be upgraded to the latest combined MSD/DEBUG OpenSDA firmware 1.14 or greater.

Issue: Is there a way to use the OpenSDA board to debug and program a target device as a Mass Storage Device without switching between MSD and DEBUG OpenSDA applications?

Solution: Starting from firmware version 1.14, P&E combined MSD and DEBUG functionality into a single board dedicated firmware application. If you are not using OpenSDA application version 1.14 or higher, please download the latest OpenSDA firmware from the P&E website and update your board with the latest firmware corresponding to your OpenSDA board. Important: All P&E OpenSDA Mass Storage Device firmware v1.14 or higher also includes support for Windows 8/8.1, MacOS, and Linux operating systems.

You have to do it in a PC whit Windows XP or 7. After you can copy the firmware of mbed from windows 8.1

posted by Jose Luis Vicente 19 Jul 2014

2 Answers

7 years, 3 months ago.

Hello i am a teenage girl and i can't get this to work. As you know teenage girls are excellent at everything. This is not excellent. My arduino works fine on windows 8.1. I'm really having to work hard to get this vexatious thing to work. Just wanted to let you know! Arrrrrrrrrgh!

The easiest solution is to do the mbed firmware update on an older windows version. This only needs to be done once, after that it should work properly on a windows 8.1 pc.

posted by Erik - 17 Aug 2014

i just tried on a Windows 7 machine. The KL25 does the same thing. ONLY shows up as "Bootloader" . I tried downloading new PE micro stuff but same thing.. only shows "Bootloader". PS i like kittens, do you?

posted by Enilorac G 17 Aug 2014
7 years, 6 months ago.

I am using 8.1 and downloaded the new file and tried the process but still does not work. Windows can't detect it and nothing occurs.

Now, if I hold the button down the Bootloader DOES work and I drag n drop the new file, unplug and re-plug and nothing occurs.

I don't know if there is a process to update the bootloader completely from within windows 8.1, but I just used one time an older PC (windows 7) and updated the mbed firmware with it, after that it works fine.

posted by Erik - 16 May 2014

Well, I now tried from Windows 2003 .NET RC2 Server, Ubuntu Wheezy, Raspbian, and now Linux Mint. It doesn't matter what I use or cable, it won't upgrade, I get the Bootloader but thats it.

posted by lance seidman 20 May 2014

Iance, try Windows XP or Windows 7, you should be able to flash the firmware on it. Once you did that, you can use Windows 8, or any Linux distro to upload compiled codes.

posted by S. Ken San 17 Aug 2014