6 years, 6 months ago.

Lpc1768 mbed on Windows XP embedded - no disk drive

Hi, me again.

Today I moved my recent project to the platform it was built for. Basicly it's a Waffer LX computer running Windows XP embedded. I have installed all the drivers, I am able to communicate via serial communication. I see the mbed disk drive in the device manager under disks, I see the mass storage device under USB devices, but I can not see or access the mbed thumb disk unde "My computer" window. It's not an bad cable issue, because on my desk computer running WinXP SP3 works fine. I tried a brand new, out of the box mbed, and nothing. The drivers installed automatically, allso the drivers for the mass storage, everything went fine, but still, no disk under my computer. I've tried to uninstall and reboot the computer, but still nothing. Tommorow I'll try to upgrade the mbed fw with http://mbed.org/handbook/Beta. I need to see the disk, because I have to switch between 2 different BINs (related to my latest questions). Any help would be verry appreciated.

RGDS.

i do think you can try it on linux (ubuntu). I face this problem occasionally even in windows7.

posted by Arijit Souradeep 05 Jun 2013
Comment on this question

1 Answer

6 years, 6 months ago.

Some progress was made. I solved the problem with mass storage with BOOTICE.exe, but now, mbed prevents booting the PC. I have only HDD selected in BIOS in the boot priorityes, no USB devices. The boot fails prior the BIOS check for avail. disks, so it's not an "not bootable disk" issue. Basicly, the boot fails in the middle of RAM check. If I disconect MBED, the PC starts normally. This is a big problem to me, because the MBED device is going to be a part of this modified computer, so phisically disconecting and then reconectig it after the boot is done is out of discussion. Any sugestions?

RGDS


You need to log in to post a question