A world leader in providing the semiconductor solutions that make a positive contribution to people’s lives, both today and in the future.

only 12.0KB see storage

01 Aug 2015

FAIL.TXT The interface firmware FAILED to reset/halt the target MCU

DETAILS.TXT Version: 0221 Build: Apr 29 2015 13:11:12

only 12.0KB

use the "0 byte" is...

I tried to apply all updates, but does not operate.

how do you do apply?

02 Aug 2015

Make sure that the two STLink jumpers are inserted (set to NUCLEO) and make sure the power jumper JP5 is set to U5V.

03 Aug 2015

Checked OK.

I did not touch the jumper. This is the default state.

03 Aug 2015

I had a very similar problem, but with Nucleo as a programmer and a separate pcb with the target processor. After several successful programming, suddenly "FAIL.TXT, 12KB ... etc." and the total lack of contact (even by ST-LINK Utility). Nucleo as a programmer was OK because other processors programmed without any problem. Processor back to life only after setting at pin boot0 = High before connecting Nucleo to USB cable. FAIL.TXT disappeared, and can be programmed.

If you still have this problem, try to close boot0 pin to pin + 3.3V, before connecting Nucleo to a PC. These pins are next to each other, so you can use the jumper (spare jumpers are on the bottom of Nucleo). If Nucleo disk free space will show correctly. then you can try programming. Once programmed, simply remove the jumper and reset the Nucleo.

26 Aug 2015

I have the same problem ...

Installing the USB driver (Windows 7 64bit) was successful. The update of the firmware on the Nucleo-F401RE was also successful. The free space of the F401 is displayed correctly in Explorer. Nevertheless, it is not possible to store files greater than 12K.

Even the hint of "Nothing Special" has no success. I tested the F401 to 3 computers. Always the same bad result.

Do you have any ideas?

26 Aug 2015

Have you tried "ST-LINK Utility"?
This program, among other things, displays the available memory and processor type. You will know whether the target and the connection is ok.
And it uses a different driver on Widows, if this would be a problem.

27 Aug 2015

With the ST-Link Utility it works fine. You're right. The utility appears to take other drivers ... the method using Windows Explorer is still unsuccessfully.

Thanks a lot!

06 Sep 2015

I have the same problem, the FAIL.TXT is being created everytime I drag&drop .bin files, but the flash size is still 512KB.

I have upgraded firmware version (however it was already updated), but did not help anything. I tried ST Link Utility, it says "Can not read memory, please disable Read Out Protection and retry". I tried to disable it in Option bytes, it was set to Level 1, trying to change it to level 0 will result in error.

did anyone succeeded recovering his board?

06 Sep 2015

Just to restrict the possible issue, i would suggest to open stlink utility and:

- does the target cpu gets recognized (top right window)? Do you see Device, dev id, rev id, and flash size (unknown flash size or 512k)? If you see device and dev id, SWD between stlink and mcu is at least working. If you see all the above but unknown flash size, it probbly means you have enabled some locking in option bytes (flash size, if i'm not wrong, is stored somewhare is OTP flash or bootrom, don't remember exactly). - it tells "can't read memory, disable readout protecion" upon device connect to stlink utility. "memory display" is set by default to 0x08000000 (flash), set it to 0x20000000 (internal ram) and size whatever small (like 0x200), does it show memory (it should even if locks are enable in option bytes) or does it still report error? What error? If it shoes data, it means stlink SWD is ok, just messed up with the option bytes. If shows errors also in reading internal ram, it means there is something bad with the SWD connection between onboard stlink and nucleo mcu. - go to menu "target" and then "MCU core", does it show any error or message like "read out protection activated"?

these are the default option bytes for F401, other mcus should be quite similar /media/uploads/Geremia/optionbytes.png

30 Mar 2017

It happens that I received a nucleo-L476RG board a few weeks ago, also only seeing 12k of files inside 32k total disk capacity, with stlink firmware 2.28. STLINK32 tools keep complaining impossible to connect. I tried linking the boot0 and 3V3 together and see no help. Interestingly the voltage from 3V3 pin is only 0.03V according to my voltmeter. Yet the 5V pin really gives 5V, above the GND level. At such I suspect that the 3V3 has died or never ever working. By plugging the jumper to E5V and supplying a 3V3 from other source to the board, it works now! The USB drive becomes 1MB and the expected drag'n'drop programming operation now runs smoothly.

I saw a big piece looking like AMS1117 on the board but I think it does not really function as it should. The QC of this board is yet to be desired.

31 Mar 2017

Finally found that the cause is with the 5V -> 3.3V convertor on board. This tiny DFN6 chip is from ST and Is DOA. I never ever see the LD2 lamp flashing as described by the package instruction. Now I wired an external AMS1117-3.3 module between the jp5 (U5V pin) jumper and the JP6 (VDD pin) jumper and everything work as expected.

Judging from the all-ST board components this nucleo is simply a showcase project from ST. Unfortunately it is also a failed showcase. I sure will never get this 3.3v regulator chip for my own projects.