dead mbed

17 Aug 2010


My mbed suddenly stopped working today. I noticed this when the MBED drive did not show up during restart.

I checked the Vin and GND pins and it correctly reports 5V. I also checked the Vout pins and it reports 1.? V.

The blue LED does not glow. Moreover, none of the 4 LED glows when I reset the device.


Is my mbed dead? Please help.



17 Aug 2010

One more thing:


When I connect my mbed to my USB (Linux) nothing shows up in the "dmesg" output. No "USB connect" event is show in the status log.



17 Aug 2010
Try plugging in your mbed while you hold the reset button. This has worked for some people when working with the filesystem.
17 Aug 2010

Thanks for the reply


But it doesn't work. I kept the reset button pressed when I switched mbed on. Then I plugged in the USB.


Nothing happens.

17 Aug 2010


Have you tried powering the mbed microcontroller from the VIN pin?

Can you also give us some back ground on what you have wired up to your mbed (a circuit diagram would be good), and what your software was doing at the time.

Any other information you have would be great.