Ethernet speed setup?

25 Feb 2010

Hi all!

I am trying to use mbed's ethernet features. If I use it on a 100base-tx switch, it works properly. But if I want to plug it into a quite old 10base-t HUB with my notebook in order to monitor its traffic with Wireshark, the connection does not work. The link led is on, but there is no traffic. The code which worked with a 100base-tx switch doesn't work with this HUB. I tried with different cables, the results were the same. The HUB is OK, as two notebooks are connected to it and no problem with that.

I can only think that maybe the API initializes the PHY interface chip to operate at 100mbit only, without auto-negotiation. Unfortunately the initialization source is not open and I couldnt find any description that tells something about the ethernet settings. And the pins on LPC are so small that I couldnt measure the LED_SPEED signal... :)

Does someone know something about this?



13 Jul 2010 . Edited: 13 Jul 2010

Hi! I am facing some problems as well with the Ethernet Setup speed. I am using the MyEth.set_link(FullDuplex10); in order to reduce the speed of the Ethernet.

The problem is that I am not configuring the code well. It create errors in that line! May I have the appropriate syntax?

13 Jul 2010

Try MyEth.set_link(Ethernet::FullDuplex10);

13 Jul 2010

Perfectly working! Thank you!!!


23 Apr 2014


I've got the same problem with my UDP protocol, can you post your own code please ?

thank you ,best regards