Programming mbed via Software

19 Mar 2012


I am using XBee TRX Modules to connect my Notebook with my mbed. I have written programs to upload a program to mbed via XBee using LocalFileSystem to save the File. The Upload is working and the file is correct (I checked hash values). Then I reset the mbed with mbed_reset(), but the new software is not getting flashed. It is restetting as if there was no change. If I reset the mbed by hand there is still no new software running.

The only way I is to upload via USB File System. Is there an alternative way to tell mbed that there is new software available?

19 Mar 2012

<<quote BlazeX>> <</quote>>

i think the only option via software at this point is to delete all other .BIN files. unfortunately the file system implementation doesnt use or allow for modification of timestamps.

19 Mar 2012

I have tried to delete all bin files by hand, but still no new software. Only when I upload a new File via USB it is getting flashed on reset.

Is it possible to flash the mbed manually? Not by bootloader.

19 Mar 2012

<<quote BlazeX>><</quote>>

all BUT the firmware you want to load? hmm, i have a similar system over HTTP that works fine. there is also this but i found it to be unreliable and messy.

AFAIK, it's possible to upload a binary and i imagine it's likely you can execute it. i cant positively answer this one though. if your mbed resets though, the "magic" will overwrite anything so make sure you at least have some normally flashed binary acting as a bootloader.

20 Mar 2012

Yes thanks chag! Deleting all Binaries and using another name for the new Firmware solved the problem!