Windows 7 can't see mbed

09 Apr 2012

Has a definitive solution to this issue been found? I bought an mbed about a month ago, it worked fine and I was able to download some basic blinky programs to it for testing, I know it worked because I tried several demo programs, but I was busy at that time and put the mbed away. Yesterday I took it out of the box again but this time I'm completely stuck.

I can only get Windows to recognize the mbed if I hold down the reset button and plug in. If I format it and the flash memory is blank, Windows sees it fine, I can see MBED.HTM and can drag and drop files, but once I reset or let go the reset button, the program starts to run, and the mbed drive disappears. If I plug the mbed in when there's a program in memory, the program starts to execute, but Windows either does absolutely nothing, or gives me a USB device error 43.

It's not the USB cable as I've tried every single USB cable I have, and I have a LOT. The mbed itself is fine since it works on my Windows server box and my home Macbook (using any cable, I tested). It doesn't work on my Thinkpad X61, and it doesn't work on my colleague's Thinkpad T61. Both notebooks are Windows 7 Pro SP1. Could it a be notebook USB thing or some software conflict? Both Thinkpads are work computers and have a lot of applications installed. (I'm a Windows sysadmin and my colleague is tech support.) The server is a test server and only has Windows and SQL 2008 R2 installed, and the Macbook is my home computer and runs Windows 7 Ultimate SP1 and only has basic apps.

I've tried uninstalling the mbed mass storage driver and all USB related programs and drivers. Tried plugging in the mbed when logged in as the administrator user. Tried changing autoplay/autorun options. Also already tried everything the deadmbed page suggested.

Technically my mbed still works, as I can hold down the reset button, and I can drag and drop files to it with the button held down. Will try installing a new copy of Windows on a blank drive later on and see if it's Windows or my notebook...

Sorry for the long (and first!) post, but I've been trying different things for more than 15 hours and I really want to get things going.

09 Apr 2012

Have you tried the hello world binary on the mbed. The mbed drive disappears on the pc side when your program is accessing the hostfile server and doesnt release it.

09 Apr 2012

Yes, I'm only using the Hello World binary. From reading similar problems on the forum, my issue is almost exactly like mbed accessing the local file system, but I'm not doing anything that advanced yet, just blinking LEDs.

09 Apr 2012

Hi It could be a USB thing, I had an issue yesterday where the mbed was running a http server but kept resetting and the drive appeared sporadically in device manager. I was chatting on Skype at the time and after a while head scratching realized it was my HD webcam causing the issue as soon as I deactivated my cam the mbed fired up fine, Win7 64 bit.

09 Apr 2012

I've tried booting Windows 7 into safe mode too. Didn't work. Just now I went to try the mbed on my team mate's ThinkPad R400. The R400 is a much newer model than my X61 and doesn't have USB current problems (it can charge the iPad while my X61 can't), but it also didn't work. Symptoms are identical.

I'm almost out of ideas, but I'm not giving up yet. Will try installing Windows, and will bring in my infinite supply of USB cables.

The strangest thing is, it worked just fine a month ago when I first got the mbed, why not now? Am I missing something incredibly obvious? :(

09 Apr 2012

Has there been a windows update since then ? maybe a driver/update issue could try rolling back to when it worked

10 Apr 2012

Hmm, I think the problem is hardware related and not OS related, as I tried booting with both Windows and Linux Live CD's and I still couldn't see the mbed inside those environments. (How the heck did I use it the first time?!)

Anyway, I discovered a workaround so I'm posting it here for future reference. I found that if I use a USB hub then my mbed works fine. This is opposite of the usual advice of bypassing USB hubs and plugging the mbed directly to the computer. There's probably a hardware incompatibility somewhere and using the hub makes the problem go away.

The USB hub I'm using is a simple generic 4-port unpowered hub. In fact, after using the hub, I tried ALL my USB cables and they all work fine. Previously, some cables "seem" work slightly better than others since holding down reset and plugging in doesn't work for some cables too. In fact, I managed to find some super long USB cables and they all work fine, as long as the USB hub is used.

15 Apr 2012

I'm adding a footnote to this thread, using the beta firmware (v21164) solves this problem for me. No more USB hubs, and any cable works.

I also realized why I could use the mbed when I first got it. I installed the beta firmware immediately after getting my mbed, but because I'm new to mbed, I was afraid the beta might introduce differences because the page also talked about a beta library, so I went back to the release firmware.

Edit: Sigh, maybe not, after a day of working fine, all of a suddenly it stops being seen again. Back to the USB hub...

11 Jul 2012

I am a new mbed user and the mbed is working fine as long as I use the USB port I first started it with. If I move to a different UBS port I don't see the mbed as a drive. When I switch back to the UBS port used to install and test every thing seems normal. I will continue to look for similar problem discussions. My system is windows 7 / 64 with many USB ports. Any suggestions?

Please log in to post a reply.