RF52-DK compiled .hex files crash upon connection

08 Oct 2017

I have an RF52-DK. I can program it by dragging .hex files on the the JLINK drive (if I upgrade to the version that has a drive named mbed it fails to program, I guess this is a known issue with Windows 10), and I've tried the proximity_demo from nordic, which works. I can connect and do all the things the readme says I can do.

But I can't get ANY examples from mbed to work, I've tried BLE_button, BLE_batterylevel, BLE_LED, and BLE_LoopbackUART. They all work at first, blinking the LED, and advertising a bluetooth device. I use LightBlue Explorer on my phone, and I can see it there (though the name is ALWAYS NordicProx which is weird). I can modify the code to add other LEDs, or print info to serial and read it out. But if I try to connect with LightBlue, it crashes. The LED stops blinking, and serial printing stops.

I must be doing something basic wrong.


08 Oct 2017

The imgur url is a link to a screenshot of the mbed ide after compiling BLE_Button, in case that contains any hints.

18 Oct 2017

I found that I needed to forget the "Nordic_PROX" item in the settings on my iphone. But despite that, I still cannot get the basic examples working. I've tried flashing from my windows 10 machine, and from a mac. In both cases, I see the LEDs behave as programmed, and serial communication to my pc works. I see a device on my BLE scanners, but the device is named incorrectly and any attempt to connect to that device causes the program to crash.

Please log in to post a reply.