Is project export working for code red?

04 Jan 2013

I exported a project and brought it into the lpcxpresso code red environment but it seems that the mbed library itself is missing. The project is constructed with -lmbed on the linker command line but the exported project does not have libmbed.a in it. I tried removing -lmbed from the linker command line but of course I get tons of unresolved externals. I also tried one of the GCC exports to see if it had the library but it doesn't either. Am I doing something wrong? I updated the mbed library in the online compiler to the latest version prior to exporting.

thanks, steve

05 Jan 2013

So I think this is a bug. I went back through the mbed library releases and I see that up to release 43 it contains libmbed.a. Starting with release 44, made in November, comment "Complete refactoring of the mbed library to move the target dependent code to a thin well ...", there is no libmbed.a that I can see.

For my project, I imported release 43 of the mbed library, built, exported, and built in code red and now I am able to build completely and debug my project. This contrasts to building with the latest release 53, which doesn't have libmbed.a, and fails to build in code red.

thanks, steve

06 Jan 2013

libmbed.a was renamed to libcpp.a recently. Changing your linker line to use -lcpp instead of -lmbed might help.

07 Jan 2013

Thanks for the pointer Adam. I'll give that a try. However the export process is creating the project to refer to libmbed.a, so there is still a problem with the export process that needs fixing.

BTW this flow is working pretty well for me for debugging, so thanks ARM mbed team for putting this external tool flow together!


07 Jan 2013

I hope it helps.

Steve Ravet wrote:

so there is still a problem with the export process that needs fixing.

Agreed! Hopefully this is all that is wrong since the workaround is simple and should be a simple fix for the mbed team to make as well.