Error: Flash Download failed - Target DLL has been cancelled

15 Jan 2017

/media/uploads/kwalsh/error.jpg "PDSC: Cannot recover from reset" from console as well.

Hey Everyone, I feel like I've exhausted many options trying to flash to my mbed LPC1768, but I'm plagued with the above error. Everything works fine when using the mbed online compiler and dropping the binary (.bin) file onto the chip, but I would love to be able to use offline uVision5 as well for debugging.

I've followed guides to export projects from the online IDE into uVision5, but those still result in the above error. I've updated my firmware to the latest (version 141212 w/ CMSIS-DAP support) as well as my serial driver for that board in particular. I've chosen the CMSIS-DAP for debugging. I can properly see the MBED CMSIS-DAP, mbed Serial Port, and MBED mictrocontrolleur USB device in my "Devices" on Windows 7.

As well I have the LPC17xx IAP 512kB programming algorithm. Using 12MHz for Xtal target. I think I have the correct startup and system files added (see below).


Maybe I'm missing something though, please let me know if you have any suggestions. Getting a tad annoyed at this point!

Thanks, kwalsh

17 Feb 2017

Hi Keegan: We had the same problem here at Technical University of Madrid in our laboratories with students. We have solved it using the version 2.2.0 for the Keil::LPC1700_DFP (Device Support). After that you can program the flash succefully. Hope this helps! Cheers, Julian Nieto

20 Feb 2017

We have the same problem ask method solution.

28 Feb 2017

Hi Keegan: I have same trouble in windows10. When I try to debug in uVision 5 ,I export files(LPC1768) from online mbed compiler. And I open project file on uVision. But I have troubles. 1."main.cpp" file is on no name folder /media/uploads/ueda/2017-02-28.png 2. I can't find target on "Options for Target". I connect LPC1768 but I cannot find LPC 17xx. /media/uploads/ueda/2017-02-28_-1-.png /media/uploads/ueda/2017-02-28_-2-.png

Sorry my English is so poor . Please help me!

07 May 2017

I have solved with the DFP 2.2.0 as commented by Julián Nieto. Tks Julián

14 Jun 2018

Julián Nieto wrote:


Thanks for the tip it worked for me as well. Jut out of curiosity, has anyone got the mbed LPC1768 working with MBED OS 5.0? I'm wondering if that allows debugging diretly with the latest DFP.


10 Dec 2018

I have some problem. I will try 2.2.0 for the Keil. Thanks Jullian and Samuel.

27 Aug 2019

Have you take off USB cable and reconnect it? I did here, and is working normally...