Error -230, The build system did not finish successfully

15 Sep 2015

I have trouble with compiling my program since today. It says; Error -230, The build system did not finish successfully.

Someone else having troubles with the online compiler?

note: a simple blinky program compiles fine...

15 Sep 2015

Hi Robin,

I'll pass this onto someone to have a look at. In the meantime it looks like your compiles were running fine before you updated your mbed library, if you can downgrade that again I think it should start working again.

Steve

15 Sep 2015

@Robin,

are you using beta or not? did you change anything? Updated mbed library for example?

15 Sep 2015

no, did not changed or updated anything, i'll try to use an older mbed library

15 Sep 2015

I used an mbed library from a program that compiles, does this mean that there is a bug in the newest mbed library?

My problem is solved for now...

16 Sep 2015

Solved how? There was a bug reported for ARMCC, which was fixed probably 2 months ago, reference https://github.com/mbedmicro/mbed/pull/1021. I believe you were getting this error and should be fixed in the newer mbed libraries, we can look up when this was integrated.

We are slowly moving to newer compiler version, this problem might appear therefore recommended to update mbed library. I was told this internal fault will be fixed in the compiler.

16 Sep 2015

I created the project, 4 days, 5 hours ago. Then I copied files from previous project to this project.

I remember that I compiled the program successfully, but yesterday I just wouldn't compile anymore.

I removed the mbed library and replaced it with an mbed library from a project created: march 3, 2015. And this worked...

If you want me to test something else, just let me know.

Regards Robin.

16 Sep 2015

Please provide the version of the mbed library (check revision), the current version is 106.

16 Sep 2015

It compiles fine with revision 94 When I use the latest library 106; "Error -230, The build system did not finish successfully."

16 Sep 2015

OK, thanks. We need to reproduce this, I tried to build locally RTOS demo , did not fail. I'll try to use latest mbed lib and some RTOs demos around to see if they fail. Do u have beta enable here?

16 Sep 2015

Don't think I have beta enable?

Could you give me more information, should I register or something?

16 Sep 2015

There is no beta running at the moment so don't worry about that.

If you want to enable beta mode you can do so by visiting http://developer.mbed.org/betamode/ at other times it may give you access to new features.

23 Sep 2015

I have the same problem. I'm following the sparkfun tutorial and getting stuck with Experiment 5: https://learn.sparkfun.com/tutorials/mbed-starter-kit-experiment-guide/experiment-5-internet-clock

The project stops compiling with error -230 as soon as I add the following dependency: https://developer.mbed.org/users/sparkfun/code/mbed-rtos/ This is mbed-rtos forked (but not modified) by SparkFun in Nov 2014

Since this is part of a tutorial, it surely must have compiled at some time.

23 Sep 2015

@Tobias, that RTOs is outdated and as referenced above, you might be getting that internal compiler fault (ARMCC). CAn you use official repo mbed-rtos , not a fork made by sparkfun?

23 Sep 2015

Thanks for the answer, yes official mbed-rtos works. But I wouldn't consider that a fix, but merely a workaround.

The purpose of the SparkFun fork was exactly to prevent that an experiment suddenly starts failing. The code was obviously working with some older version of armcc, so (given that it's correct C++) it should continue to work. If not, this is a bug in armcc which should be fixed. Same with my own code. I don't want it to fail suddenly after a year or so without touching anything.

Additionally, the error is rather unspecific. There's no hint to the cause of the error at all. The build system is a bit of a black box.

But thanks anyway and sorry for the rant ;-)

24 Sep 2015

Yes, it's workaround.

It is bug in armcc which we reported. it was fixed and that release might be out at the moment - I don't track the release log ;) We recently updated armcc but that internal fault is still present in that version :/

Yes, the error should be more descriptive - as it is reported when you compile offline. I'll report this.

09 Jul 2019

I have the same bug, yesterday my code compiled, but not today. Anyone in 2019?

17 Jul 2019

Yep, weirdly just recently.

24 Jul 2019

Yes I am having the same Error Number -230 when compiling an existing older program in July 2019.

The only output is below lines with no indication of where the error lies or where/what/how to fix it:

The build system did not finish successfully. Error Number -230 Unable to download. Fix the reported errors...

24 Jul 2019

Same again, today..

24 Jul 2019

What happends.? I have a error 230 !! The same, for a few minutes it works fine, now all my programm have the same error

24 Jul 2019

Hi All,

Our apologies for that, we deployed a new version of the site with an updated library, which was the cause of the issues you saw. We reverted the deployment as soon as we became aware, and we believe the system should be functioning as normal now.

James, Mbed Web Team

24 Jul 2019

Hi,

Indeed, it compiles again.

thx

01 Aug 2019

Hi, I have a error 230. Could the problem mentioned above recur?

07 Aug 2019

Hi, me too, only works blinky

14 Aug 2019

I too get Error 230!

21 Aug 2019

I also got the same error

29 Aug 2019

I also have got the same error. I could solve that error doing an update on Dht11 lib. I hope this be useful

27 Aug 2019

Hi, I am trying to reproduce this but with no luck. Would you be able to share the repo has the failure? Thanks.

03 Sep 2019

Hi all,

I too have the same "The build system did not finish successfully", 230 compile error with FRDMK64 board. Any possible ways to get rid of it?

Thanks, Shanthini

You need to log in to post a reply