1 month, 3 weeks ago.

MbedTLS File download issue STM32f429Zi

Hi Team,

I am using stm32f429zi MCU and trying to download a file from the server. I tried to download a 1Kb file, and I got success but when I am trying to download 300Kb file its getting fail. What should I do? I attached my sample code for your reference. /media/uploads/Rajkumar181/testcode.c

Could you specify what is the failure? Does it fail immediately? After a few iterations? Do you have logs? Is the server sending the file encrypted as a single 300 KB application data(a TLS record data is limited to 16KB)? I believe the issue is that you are trying to read only 1024 bytes each time, however the decryption fails, because the data received itself is more than 1024 bytes. Please try increasing TX_MAXLEN to 16KB,

posted by Ron Eldor 24 Oct 2019

1 Answer

1 month ago.

Hi Raj,

Could you see the comment from Ron Eldor and check if that solve your question?

Regards, Desmond


Assigned to Desmond Chen 1 month ago.

This means that the question has been accepted and is being worked on.