2 years ago.

Offline simulator not working

Hello, I am trying to run offline simulator. I've stuck at building libmbed, got an error "Unable to clone repository (https://github.com/janjongboom/mbed-cloud-client-1/#3be035aa2ebf4b823457932d742311d6309af435)" shown in the image /media/uploads/MichalKozlowski/error.png

Could you please help me fix this problem?

1 Answer

1 year, 12 months ago.

Hi Michal,

Can you try git clone https://github.com/janjongboom/mbed-cloud-client-1/#3be035aa2ebf4b823457932d742311d6309af435 manually, and see if the build would work?

Thanks, Desmond

Hello Desmond,

I've tried and in result get a fatal error. It looks like mbed-simulator is pointing to incorrect repository.

"Cloning into '#3be035aa2ebf4b823457932d742311d6309af435'... fatal: https://github.com/janjongboom/mbed-cloud-client-1/#3be035aa2ebf4b823457932d742311d6309af435/info/refs not valid: is this a git repository?"

posted by Michal Kozlowski 24 Sep 2019

How about just clone the mainline?

posted by Desmond Chen 24 Sep 2019

I've tried it before and it didn't help. Still can't see this repository.

posted by Michal Kozlowski 25 Sep 2019