Report
3 weeks, 2 days ago.

"Insufficient disk space on current disk. Insert another disk and type <Return> to continue..."

/media/uploads/gauri8427/picture_3.jpg /media/uploads/gauri8427/picture_2.jpg /media/uploads/gauri8427/picture_4.jpg /media/uploads/gauri8427/picture_1.jpg

I was programming stm32 using arduino ide, it was working fine for last 3 months but suddenly it gave error like "Insufficient disk space on current disk. Insert another disk and type <Return> to continue... ". And when I opened that "NODE_F401RE disk space" it contained a file namely Failed.txt with content written in that file as "The interface firmware FAILED to reset/halt the target MCU"

I tried solutions like, 1. Erasing the stm32 memory using ST -link utility, but it couldn't connect the target 2. Tried upgrading the the ST-link firmware using ST-link upgrade application, again no success. 3. I tried formatting the disk space, it gives popup as "windows was unable to complete the format". 4. All the jumpers on STM32 board are connected fine. Also, the ST link IC and STM32 MCU, both are getting heated. Please give a solution to this problem, is the stm32 board is no more workable or it can be troubleshooted.

Question relating to:

Comment on this question

1 Answer

2 days, 19 hours ago.

I have had the same issue multiple times Generally I switch to a different USB port first Then i disconnect all the jumpers and connect them back In the STLink utility click STLink and click firmware upgrade while holding both buttons on the board After the firmware update remove the USB and try again. This will not work the first few times but after a while this should sort it out usually 6+ times


You need to log in to post a question