2 months ago.

How to increase MTU SIZE?(STM,NUCLEO-WB55)

App's MTU size chaged(gatt.requestMTU)

but Board's MTU SIZE is not CHANGED.

HOW to change MTU SIZE?

Comment on this question

1 Answer

2 months ago.

Hi Shin,

You can refer to this question

https://os.mbed.com/questions/86315/Max-Size-Allowed-for-a-GATT-Characterist/

MTU size is able to be configured via mbed_app.json.

Regards, Desmond

thank you, Chen

I tried to apply your help to my code.

and I checked that a part of problem is solved.

but I can not solve that totally.

I request MTU SIZE to 512.(Phone'side)

and I also setted up MTU SIZE to 512 at Board.

as a result of checking 'onDataLengthChange",

Data length changed on the connection 1. Maximum sizes for over the air packets are: 251 octets for transmit and 27 octets for receive. update enabled on handle 14 Data length changed on the connection 1. Maximum sizes for over the air packets are: 251 octets for transmit and 70 octets for receive.

I don't know why LOG happens twice(phone request MTU Resize once)

and MTU result is 70 octets.

plz help me how to maximize MTU SIze.

posted by SHIN ETHAN 23 Aug 2019

You need to log in to post a question