3 months, 1 week ago.

Blinky doesn't work on nRF52-DK, nor does firmware update

I'm getting pretty frustrated with this. I tried compiling the mbed OS blinky both with Mbed Studio and the online compiler.

#include "mbed.h"

DigitalOut led1(LED1);

int main()
{
    for (;;)
    {
        led1 = !led1;
        wait_ms(500);
    }
}

I flashed it to the hardware, but get no blinky LED! Wtf? Ok maybe it needs a firmware update. I go to the firmware update page and it says if your board connects as BOOTLOADER, you need to update some other firmware. It links to a file called 0244_sam3u2c_bootloader_update_0x5000.bin. I tried following the instructions and it kind of seems to copy the file across, but when reset it's still BOOTLOADER!

Ok weird. Maybe there's an updated version. I found the releases on github and there is a newer version but it is 0254_sam3u2c__0x0000.bin. Anyway I tried it, and the same result. I also tried 0254_sam3u2c_mkit_dk_dongle_nrf5x_0x5000.bin but get the same result. Nothing changes it from BOOTLOADER.

Except, Nordic provide a JLink interface file, which did change the interface to J-LINK, but flashing the blinky example (from both the online and offline compilers) still doesn't blink the bloody LED.

I'm on Mac. What the hell is going on here? I already had to hack around a bug in Mbed Studio's installer to install it. This stuff shouldn't be this hard to use!

EDIT

I finally worked out the MAINTENANCE thing. You have to hold down the reset button while plugging it in, then flash 0244_sam3u2c_bootloader_update_0x5000.bin. Then power cycle it / unplug it an plug it back in again without holding the reset button. You get a MAINTENANCE volume. Then you can flash 0254_sam3u2c_mkit_dk_dongle_nrf5x_0x5000.bin. Then power cycle and you should have a details.txt file which contains:

...
Interface Version: 0254
Bootloader Version: 0244
...

However, flashing a blinky example still doesn't blink the LED, so I still can't use the board.

Ugh my bad, I accidentally picked up an old nRF51-DK! It doesn't really say it on the board unfortunately!

posted by Tim H 10 Aug 2019

Although, it still doesn't work even if I compile for nRF51-DK. I asked another question about that.

posted by Tim H 10 Aug 2019
Comment on this question

1 Answer

3 months, 1 week ago.

Hi Tim,

You can find the DAPLINK firmware here. https://armmbed.github.io/DAPLink/

So there is no issue on NRF52_DK!

Let me know if you have any questions.

Thanks, Desmond


You need to log in to post a question