5 months ago.

Error while connecting to CPU message

I recently purchased a Thunderboard Sense 2 board. Briefly, when I compile and upload programs to it in the online mbed IDE, a FAIL.TXT file is appearing in the drive/folder associated with the board. This file contains the text "Error while connecting to CPU." Any suggestions regarding how I should proceed?

A more detailed description of my situation follows...

I first tried to upload my simple mbed 2.0 Blink program to the board (this is my standard starting point when working with new boards). The compilation appeared to succeed and I saved the .bin file to the TB004 drive/folder. However, the onboard LED did not blink as expected and a FAIL.TXT file appeared in the TB004 drive/folder. This file contained a single line of text - Error while connecting to CPU. I next tried compiling the mbed 2.0 mbed_blinky_low_power program (https://os.mbed.com/teams/SiliconLabs/code/mbed_blinky_low_power) that is linked from the Thunderboard Sense 2 platform page on mbed. Again, the compilation worked and the binary file transferred, but the FAIL.TXT file showed the Error while connecting to CPU message. Finally, I tried the mbed 5.0 mbed_os_example_blinky program (https://os.mbed.com/teams/mbed-os-examples/code/mbed-os-example-blinky). The results were the same.

I next updated the firmware on the Thunderboard. I followed the instructions linked from the platform page - https://os.mbed.com/teams/SiliconLabs/wiki/Silicon-Labs-Firmware. This required downloading the full Simplicity Studio app, a nearly 10 GB installation! The firmware update appeared to work. After the firmware update, I tried uploading the mbed blink programs again and got the same results. Note: Immediately after the firmware update, the green LED in the middle of my Thunderboard was blinking. After attempting to upload the blink programs it was not.

At this point, I decided I should try a non-mbed demo, so I went to the www.silabs.com/start-sense webpage listed on the card included with my board (which displays as https://www.silabs.com/support/getting-started/thunderboard/thunderboard-sense). This demo involves displaying Thunderboard sensor data on a phone via a Bluetooth connect. At this point, I figured I needed to restore the software on the board, so opened Simplicity Studio and found the SOC – ThunderBoard 2 Bluetooth demo code. I uploaded it to the board. After this the green LED on the Thunderboard was blinking again.

The upload appeared to work. I next put the Thunderboard app on my phone. Initially, the app couldn’t find/connect to the Thunderboard. I tried pressing the Thunderboard reset button. This didn’t resolve the issue. I next cycled the power on the Thunderboard by disconnecting and reconnecting the USB cable. After this, the phone app showed a Thunder Sense # 46263 connected message and appeared to work. I could monitor board position, temperature, humidity, etc. on my phone. Pretty neat!

Question relating to:

Silicon Labs a leading provider of microcontroller, sensing and wireless connectivity solutions for the Internet of Things (IoT).
Comment on this question
Be the first to answer this question.

You need to log in to post a question