Report
2 months, 3 weeks ago.

I get a compiling error in with mbed-os-5.12.4 and NUCLEO-L432KC

I get these errors whenever I compile my code with the online compiler. I have tested it with mbed OS 2 and it worked smoothly. Any idea?

Thanks!

Warning: L3912W: Option 'legacyalign' is deprecated.

Error: L6636E: Pre-processor step failed for '/extras/mbed-os.lib/targets/TARGET_STM/TARGET_STM32L4/TARGET_STM32L432xC/device/TOOLCHAIN_ARM_STD/stm32l432xx.sct'

I reverted to a former release 5.11.5 (51d5550) and now I do not have those problems.

posted by Guillermo Robles 04 Jun 2019
Comment on this question

1 Answer

2 months, 3 weeks ago.

Whenever I get a preprocessor error in the online compiler, I just hit compile again until it completes successfully.

Thanks for your answer.

It works, eventually, though there should be a definitive way to solve the problem...

posted by Guillermo Robles 31 May 2019

You need to log in to post a question