3 years, 4 months ago.

mbed nRF51822 library compile error

I have a BLE project using board Nordic nRF51-DK, and build configuration App with Bootloader

the project used to compile ok until a week ago when I lost some work and had to revert to a saved revision., I've updated all the libraries to latest versions, - mbed revision 172 - BLE_APP revision 1208 - nRF51822 revision 638

When I compile I get the following error,

Error: Identifier "nrf_app_irq_priority_t" is undefined in "nRF51822/TARGET_MCU_NRF51822/sdk/source/ble/ble_radio_notification/ble_radio_notification.h", Line: 60, Col: 39

This is really odd because the type, nrf_app_irq_priority_t is defined in "nrf_soc.h" which is very clearly included in the file causing the problem.

I've had trouble with updated libraries before but always managed to get it going after rebuilding/updating etc, but having no luck this time. I've tried rolling mbed library back several versions but get the same error.

Has anyone seen this before, and/or have some suggestions?

Thanks in advance, Andrew

1 Answer

3 years, 3 months ago.

Hi Andrew,

Hope everything is going well.

It looks like an issue related to compiler. Have you tried doing clean build? By adding parameter -c to mbed-cli.

Regards,

Desmond