Report
3 days, 16 hours ago.

mbed-cli - mbed Python dependencies seem broken

I have Ubuntu 18.04 and have been using mbed-cli for a long time with no previous issues, but now I run into python package dependency issues when trying to use it

mkdir test cd test mbed new .

results in a message to install missing Python dependencies by going in to mbed-os and running pip install -r requirements.txt

When I go into the mbed-os directory and do as su pip install -r requirements.txt

it gives me these errors: ERROR: tensorflow 2.0.0a0 has requirement protobuf>=3.6.1, but you'll have protobuf 3.5.2.post1 which is incompatible. ERROR: tensorboard 1.13.1 has requirement protobuf>=3.6.0, but you'll have protobuf 3.5.2.post1 which is incompatible. ERROR: tb-nightly 1.14.0a20190301 has requirement protobuf>=3.6.0, but you'll have protobuf 3.5.2.post1 which is incompatible. ERROR: mbed-greentea 1.6.5 has requirement mbed-os-tools==0.0.6, but you'll have mbed-os-tools 0.0.8 which is incompatible. Installing collected packages: pyyaml, jsonschema, requests, python-dotenv, mbed-cloud-sdk, Jinja2, mbed-ls, mbed-host-tests, mbed-greentea, pyelftools, asn1ate, ecdsa, pyasn1, protobuf, manifest-tool, logbook, pyshark, semver, yattag, mbed-flasher, jsonmerge, icetea, pycryptodome, milksnake, cmsis-pack-manager Found existing installation: PyYAML 3.12 ERROR: Cannot uninstall 'PyYAML'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

the first few and last one are known, but why is mbed-greentea asking for an out dated version of mbed-os-tools

Comment on this question
Be the first to answer this question.

To post an answer, please log in.