2 years, 4 months ago.

No output for printf statement on both TeraTerm and PuTTY

So I’m doing a little coding with an ST board, the Nucleo-F746ZG.

/media/uploads/gm600/1.png

In my debugging statements, I was getting no output, so I made a test code to see what the issue was. It’s a very simple “hello world” followed by a LED blinking and a printf statement with each change of state of the LED. The LEDs on the board react as expected with all my codes so there is information being sent over to the board. However, none of my printf statements are returned.

/media/uploads/gm600/2.png

The driver is working, with the device being recognised via an ST link.

These are my TeraTerm settings. I changed the new line receive to auto after no output was being shown from CR. As you can see the baud rate is the same. But still no output.

/media/uploads/gm600/4.png /media/uploads/gm600/5.png /media/uploads/gm600/6.png

I then tried a different console PuTTY. With the same settings, still no output.

/media/uploads/gm600/7.png %20/media/uploads/gm600/8.png

So I’ve tried different hardware, switching to a new USB cable. Still nothing. I’m lost here. IDK if it is a glaring code problem or something wrong with the board, which I doubt as it had been used before me with no issues.

1 Answer

2 years, 4 months ago.

Hi there,

all looks good but from my point of view your problem is caused by a Jumper on your onboard ST-link. Remove the jumper from CN5 and it will working I think.

Best regards

J.

Accepted Answer

OMG, Thank you. I never thought to do that. It's all good now.

posted by Gladys Mba 09 May 2019

/media/uploads/Ibenme/66493097_2354442611441088_5659582322672926720_n.jpg /media/uploads/Ibenme/a.png Hi I have the same problem when I using the mDot in a MultiTech MTUDK2-ST-MDOT Developer board I set the right parameters (com ; 115200 bauds ) but i can't write anything in tera term to command mdot with at command/media/uploads/Ibenme/b.png

posted by imene ben messaoud 08 Jul 2019

Hi, I recommend to you create a new question because it will be probably different problem and I do not have any experience with MultiTech boards.

I only recommend to you read manuals and guids like here [https://os.mbed.com/platforms/MTS-mDot-F411/] [https://www.multitech.com/models/94558010LF]

BS J.

posted by Jan Kamidra 08 Jul 2019

OK thank you Jan Kamidra I will create a new post

posted by imene ben messaoud 08 Jul 2019