2 years, 4 months ago.

MBed Studio 0.4 on Mac OS 10.11.6 - no web proxy setup, targets list empty

I have difficulties to get it started and create a new blinky program.

1. No Web proxy settings means I cannot login As a workaround I switch to a direct WiFi Internet, however a web proxy setting is common for many environments. I my proxy case the screen before the login stays busy for 3 minutes than a user/passwrd dialog comes, again busy for 3 minutes with a timeout messages, no button to select skip login.

2. Target lists stays empty I don't get any target to select from. I tied to restart, I tried to remove "Mbed Programs" I tried to add a Nucleo L476 board, the drive appears, still no targets, even after restart.

Is there a workaround to get the target list working. I love to get startet with Mbed Stuido and to provide feedback.

Regards Helmut

1 Answer

2 years, 4 months ago.

Hello Helmut,

Mbed Studio tries to detect the target that is attached when it is connected using a USB cable. Please note that Mbed Studio also requires support for CMSIS-DAP (DAPLINK) debug functionality. Here is a link to the DAPLINK firmware download side: https://armmbed.github.io/DAPLink/

Thank you for letting us know about the Web proxy issue. This is something that we will look into and we will post an answer once we learn more.

Best regards,

Tres, Team Mbed

Hello Tres, even without any USB device connected the target list is empty. My expectation was that I can give the compiler and IDE a try without a CMSIS-DAP device.

I tried another Mac with 10.15 (Mojave), again no luck. With the first startup after installation I came to the login. I quitted mbed Studio to bring this Mac into a WiFi environment(non proxy). I started Studio again and it is stuck with the blue start screen for minutes.

Any advise/help would be appreciated . Regards Helmut

posted by Helmut Tschemernjak 06 Mar 2019

Hello Tres, I installed it on Windows and I got the blinky project compiled. The first time I had a timeout loading the blinky and the targets have been still empty, after I added another new Blinky program, I noticed that it is downloading stuff. Now it compiles blinky.

Any idea how I get this loaded on my Mac? Regards Helmut

posted by Helmut Tschemernjak 06 Mar 2019