Report
3 months, 2 weeks ago.

Mbed online complier not even starting up

Hi everybody

I just added a new project (from an other person) into my compiler. First the compiler showed the new project.Then I made some changes and wanted to store it. The compiler page hanged for infinite after this, so i closed my browser and restarted it. Now i can not even open my compiler page anymore (neigther with firefox nor internetexplorer). Is there a possibility to delete this aded project from my project without the need of the compiler page?

Please help, i've done some serious work on my projects....

Regards, Michael

Do you get a 'loading ...' message but never actually finishes loading? You can try logging on and take a look at your Console page but NOT starting the compiler page, then select 'log off' before closing your browser. Wait for 10-20 minutes and try to load the compiler again by login in. I have found this seems to 'unjam' things particularly after importing files/libraries.

posted by Paul Staron 04 Mar 2019

Hey Paul

I just waited for about 30 min and tried again. After this timespan I was able to open my compiler page like usual and remove the recently added project. It seems like there was a problem with a shared libery (I'm not sure though). Anyway, waiting did the trick. Thank you for your help!

Regards, Michael

posted by Michael Peter 04 Mar 2019
Comment on this question

4 Answers

3 months, 2 weeks ago.

I'm also suffering this problem. I'm waiting for 30 minutes.

3 months, 2 weeks ago.

Also in the same state. It seems the server is either down or having problems.

3 months, 2 weeks ago.

https://ide.mbed.com/compiler responds with "502 Bad Gateway nginx/1.15.6" ...

it works now :-)

posted by Richard VITALIS 05 Mar 2019
3 months, 2 weeks ago.

Please see the response posted here: https://os.mbed.com/questions/84957/Online-compiler-is-down/

Tres, Team Mbed


To post an answer, please log in.