Report
2 weeks ago.

Clearing the virtual memory on NUCLEO-F411RE.

I've compiled and tried to upload the blink program of the mbed templet. When I tried to upload the program. It tells me that I have no space left. The jumpers have not been touched, that I know of. I have tried to format it with windows format, windows gave me an error. I also tried to update the firmware and there is still not enough space.

Question relating to:

Affordable and flexible platform to ease prototyping using a STM32F411RET6 microcontroller.
Comment on this question

2 Answers

2 weeks ago.

It sounds like the main CPU (F411) is not powered. What is the status of *every* LED on the board? Make sure the jumpers all match the Nucleo user manual settings and re-plug the board. If it still doesn't work then the board might be failed :(

LD1 is red, LD2 is blinking green, LD3 is red, I Have matched the jumpers with the ones on the user manual and still nothing.

posted by Ke'Ondrae Mell 09 Feb 2019
1 week, 4 days ago.

I think it could be an issue related to the stm driver installation (v-link). Pc see the board as usb memory (with very limited space) if the stm driver is not properly installed. check it. Bye Lorenzo


To post an answer, please log in.