2 years, 7 months ago.

mbed-dev import failed

I am trying to import mbed-dev, but getting errors:

----------------------------------------------------------------------------------------------------------------------
mbed add -vv https://os.mbed.com/users/mbed_official/code/mbed-dev/

[mbed-3908] Working path "C:\mbed-cli\workspace\LoRaWAN-hello-world" (program)
[mbed-3908] Adding library "mbed-dev" from "https://os.mbed.com/users/mbed_official/code/mbed-dev" at latest revision in the current branch
[mbed-3908] Trying to guess source control management tool. Supported SCMs: bld, git, hg
[mbed-3908] Exec "git clone https://os.mbed.com/users/mbed_official/code/mbed-dev C:\mbed-cli\workspace\LoRaWAN-hello-world\mbed-dev -v" in "C:\mbed-cli\workspace\LoRaWAN-hello-world"
Cloning into 'C:\mbed-cli\workspace\LoRaWAN-hello-world\mbed-dev'...
fatal: unable to update url base from redirection:
  asked for: https://os.mbed.com/users/mbed_official/code/mbed-dev/info/refs?service=git-upload-pack
   redirect: https://os.mbed.com/users/mbed_official/code/mbed-dev/info/refs/?service=git-upload-pack
[mbed-3908] Exec "hg clone https://os.mbed.com/users/mbed_official/code/mbed-dev C:\mbed-cli\workspace\LoRaWAN-hello-world\mbed-dev -v" in "C:\mbed-cli\workspace\LoRaWAN-hello-world"
requesting all changes
abort: HTTP Error 504: Gateway Time-out
[mbed-3908] ERROR: Unable to clone repository (https://os.mbed.com/users/mbed_official/code/mbed-dev/)

----------------------------------------------------------------------------------------------------------------------

This is happening for two days, i have tried different pc, networks.

Also the project uses below mbedlib version: https://mbed.org/users/mbed_official/code/mbed/builds/97feb9bacc10

So the corresponding mbed-dev url will be, (right?) https://os.mbed.com/users/mbed_official/code/mbed-dev/#e13f6fdb2ac4

I also tried with above link, but still getting gateway timeout.

2 Answers

2 years, 1 month ago.

And if someone wants to not use the precompiled libraries I guess we're just SOL then? Why was mbed-dev taken down?

2 years, 6 months ago.

Hi Sol,

Did that command work for you in the past?

The OS2 Mbed release site is:

https://os.mbed.com/users/mbed_official/code/mbed/builds

If you start from a fresh folder, this should work for you:

  mbed config root .
  mbed add -v https://os.mbed.com/users/mbed_official/code/mbed/builds/97feb9bacc10

You will then have the 140 release of the Mbed library in the project space and you can then add your source files.

Regards,

Ralph, Team Mbed

I am able to import mbed library into to my project without any issue. But i want to modify some mbed source file to suit my application, for that purpose i want mbed-dev source files. So while trying to download the mbed-source, i am getting 504 error which i have already mentioned in my previous post.

posted by a22z sol 04 Jan 2019

The dev repo is huge and might timeout because of it. You can manually clone it with limited history (fetch only the latest one) - use depth argument and see if that helps

posted by Martin Kojtal 04 Jan 2019