12 months ago.

Unable to use online compiler

When will the Script Not Found error be fixed with the online compiler?

Question relating to:

The BBC micro:bit is a pocket-sized, codable computer that allows anyone to get creative with technology. Made possible through a major partnership with 31 organisations, a micro:bit has been given ...

DId you find a way to get it working with the CLI ? The linker script error appears both in the conline compiler and the CLI for me.

posted by Jonathan Piat 15 Oct 2018
Comment on this question

1 Answer

12 months ago.

Hi Martin,

We are aware of the issue with the online compiler and Mbed 2 targets and are currently working on a fix. In the meantime, you can also use the offline Mbed CLI to compile for the micro:bit, a quick start guide for the Mbed CLI is available here: https://os.mbed.com/docs/latest/tutorials/quick-start-offline.html & an easy installation guide is available here: https://os.mbed.com/docs/latest/tools/installation-and-setup.html

In addition, there is also a bug with the micro:bit and the Mbed CLI with the ARM C5 toolchain: https://github.com/ARMmbed/mbed-os/issues/8344 so in order to use the Mbed CLI with the micro:bit you will need to use the GCC_ARM toolchain: https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads

We apologize for the inconvenience. Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

I tried with an up to date mbed-cli (latest one on github) , the GCC_ARM target and i get the following error :

IndexError: list index out of range

can you indicate a version of mbed-cli that would work.

posted by Jonathan Piat 24 Oct 2018

You need to log in to post a question