1 year ago.

Compiling for Micro:Bit - "No Linker Script Found"

Doesn't matter what I do, old projects new projects, all I get is "No linker script found". I'm using the online compiler with URL https://os.mbed.com/compiler/#nav:/mbit_send/main.cpp; - that's a bare naked untouched new project - and I still get the error. What can I do to fix this?

I'm suddenly having a similar issue and would greatly appreciate any help from the mbed community to resolve it.

posted by james hatch 05 Oct 2018

I am also facing the quite same error while building my header file. I'm using the online compiler with URL https://ide.mbed.com/compiler/#nav:/AS7263/AS726X.h;- How to fix hit?

posted by Sonali Shukla 27 Feb 2019
Comment on this question

1 Answer

1 year ago.

Hi Robert,

We are aware of the issue with the online compiler and Mbed 2 targets and are currently working on a fix. In the meantime, you can also use the offline Mbed CLI to compile for the micro:bit, a quick start guide for the Mbed CLI is available here: https://os.mbed.com/docs/latest/tutorials/quick-start-offline.html & an easy installation guide is available here: https://os.mbed.com/docs/latest/tools/installation-and-setup.html

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

The mbed-cli for the BBC:microbit may only work for the arm compiler but it does not work for the arm_gcc compiler.

posted by Jonathan Piat 11 Oct 2018

Hi Jonathan,

I am having the opposite issue, for me I can compile successfully with: mbed compile -t gcc_arm -m nrf51_microbit but I cannot compile with the Arm toolchain: https://github.com/ARMmbed/mbed-os/issues/8344

Please keep an eye out on that GitHub issue for updates regarding the missing linker script files for the micro:bit.

- Jenny, team Mbed

posted by Jenny Plunkett 11 Oct 2018

Hi, the GCC_ARM toolchain doesn't work as mentioned, and the Arm toolchain is not available on Mac OS which is what I am using. Any other workaround available (aside from installing a Linux or Window VM) or any target date to fix the original issue (i.e. the missing linker script) for the online compiler? I am stuck at the moment. Thanks, Roberto

posted by Roberto Sandre 19 Oct 2018