1 year ago.

Can't create the hex file for micro:bit, message is "No linker script found"

With any default sample for micro:bit on mbed site or compiler

"No linker script found" message shown.

-Hello world on the mbed site, -microbit_blinky from compiler template

with Win10/mac book, same result. new mbed site ID created but result is same.

How to solve this?

Question relating to:

The BBC micro:bit is a pocket-sized, codable computer that allows anyone to get creative with technology. Made possible through a major partnership with 31 organisations, a micro:bit has been given ...
Comment on this question

1 Answer

1 year ago.

Hi Takeshi,

We are aware of the issue with the online compiler and Mbed 2 targets and are currently working on a fix. In the meantime, you can also use the offline Mbed CLI to compile for the micro:bit, a quick start guide for the Mbed CLI is available here: https://os.mbed.com/docs/latest/tutorials/quick-start-offline.html & an easy installation guide is available here: https://os.mbed.com/docs/latest/tools/installation-and-setup.html

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Thanks, please comment if you finish.

posted by takeshi murakami 06 Oct 2018

How long will it take to get this fix applied? Working with kids in upcoming workshops and would like to be able to use the site, instead of the CLI.

posted by Martin Stone 13 Oct 2018

I'm also wondering if and when this might be fixed as I too have a class I want to teach using this tool and micro:bit?

posted by Gordon Moore 22 Oct 2018

You need to log in to post a question