Report
5 months, 4 weeks ago.

USB port not found in terminal program

I've successfully powered up a C027 unit and installed the HelloWorld LED blinking program by dragging from the Mac Finder, and I am able to determine the device is usbmodem1412 from the /dev/tty command, however, two different terminal apps report "port not found" when I try to communicate. Any tips?

Comment on this question

1 Answer

5 months, 3 weeks ago.

Hi Peter,

Please run the ls /dev/tty.* command in your terminal again to verify that your serial port is correct. Then, run the following command to open a serial port viewer within your terminal: screen /dev/tty.usbmodem1412 9600 –L replace the /dev/tty.usbmodem1412 port number with the correct value for your board.

If this still does not work, please make sure you have tried the following troubleshooting steps:

  1. Restart your computer and power cycle the board (unplug and replug back in to your computer)
  2. Use a different USB port on your computer
  3. Use a different USB cable
  4. Make sure your board is receiving enough power (does it require an external power source?)
  5. Update your board's firmware: https://os.mbed.com/users/ublox/notebook/ublox-C027-Update-CMSIS-DAP-Interface-Firmware/

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

The problem was solved by the firmware update. I'm surprised that the hardware unit was shipped with firmware dating from 2013.

posted by Peter Miller 29 Aug 2018

To post an answer, please log in.