Report
2 months, 2 weeks ago.

Offline mbed-simulator not working

/media/uploads/mpule/mbed-simulator_error1.png Hello,

I'm new to Mbed and I have installed Mbed-CLI, Emscripten SDK and Node.js 8.11.3 LTS. When I try to run the command "mbed-simulator ." from the "mbed-os-example-blinky" I get the error shown in the image (/media/uploads/mpule/mbed-simulator_error1.png ).

Could you please assist with setting it up properly.

Question relating to:

Comment on this question

1 Answer

2 months, 1 week ago.

Hi there,

I've spoken with Jan (the creator of the Mbed Simulator tool) and he tracked down the issue and has pushed a fix to the Mbed Simulator repository. If you've installed Mbed Simulator with npm please use the following command to update your installation: npm update mbed-simulator -g

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hello,

Thanks for your response.

I have updated my mbed-simulator installation and when I run the command "sh build-demos.sh" following the instructions on the repository, I still get the following result:

C:\emsdk\node\8.9.1_64bit\bin\node_modules\mbed-simulator>sh build-demos.sh Building demos/bd... libmbed.bc does not exist. Building... 'mbed deploy' did not run before, running...

posted by Mompoloki Pule 16 Aug 2018

To post an answer, please log in.