1 year, 4 months ago.

Compiling Error

Error: "/tmp/vx6V3T", line 124 (column 3): Warning: L6312W: Empty Execution region description for region RW_IRAM1 Error: Symbol user_perthread_libspace multiply defined (by /build/mbed-os.lib/rtos/TARGET_CORTEX/rtx5/RTX/Source/rtx_lib.K64F.o and /build/mbed-os.lib/rtos/TARGET_CORTEX/mbed_boot.K64F.o). Error: Not enough information to list the image map.

Hello, I am new in Mbed, I was trying some tutorial. So added a library, and compile it first before even editing the code in main.cpp. it gives me above error.

How would I fix that error and what is the reason behind this error?

Please let me know,

Comment on this question

1 Answer

1 year, 4 months ago.

Hello there,

This has been an issue for programs using Mbed OS 5.9.2. There is a github issue that has been raised:

https://github.com/ARMmbed/mbed-os/issues/7422

If you are using the online compiler:

Under the Compile button, navigate to Compile Macros and add _RTE_ in the text box. Then try recompiling.

I was able to successfully compile the program through these steps. Hope this helps!

-Karen, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Thank a lot , It did fix the problem.

posted by Mahdiul Chowdhury 18 Jul 2018

Hi there,

I have tried this solution but it is not working. The error still persists, the link to Github just says to do the same thing.

Any other ideas? Thanks

posted by Jacob Horgan 16 Mar 2019