Report
2 months, 1 week ago.

Setup bootloader to program board without MAX32625PICO

Hello! Good morning,

I received a MAX32620FTHR to participate in the Hackster contest. So far, I had been working using the "Arduino Setup": Connecting the board directly to the PC shows the BOOTLOADER DAPLink interface, and the Arduino IDE is able to generate the image file and upload the code to the board.

As I wanted to debug using the serial interface, I connected the MAX32625PICO to the target board, and after not being able of using the serial port (driver configurations), I ended up uploading to the board the image files obtained here: https://os.mbed.com/platforms/MAX32620FTHR/

and now the board does not connect automatically when plugged to the PC using USB. In order to program it, I have to use the MAX32625PICO, and use the "MAX32620FTHR" option while using Arduino IDE (or drag and drop program files that do not include the bootloader functionality).

I want to recover the previous functionality, programming using the bootloader and only the MAX32620FTHR. Is there any copy of the program uploaded by default to the board? I am not sure if I will need specific instructions to install the bootloader again.

Thanks a lot in advance for your time, Regards, Jorge

Question relating to:

MAX32620FTHR Rapid Development Platform
Comment on this question

2 Answers

2 months ago.

Hi.

I had same problem.

Solution:

https://maximintegratedsupport.force.com/support/s/article/How-can-I-restore-the-MAX32620FTHR-bootloader-when-erased-accidently

Regards, MagSem

Hi, thanks for your answer. I am having a problem with that bin file, I get a FAIL file error, with the following message:

The application file format is unknown and cannot be parsed and/or processed.

I am following exactly the method described here to upload the file: https://os.mbed.com/platforms/MAX32620FTHR/

With the same board: MAX32625PICO-board as a programmer Am I missing something?

I will post here the contents of details.txt file of my programmer in case that can be useful:

  1. DAPLink Firmware - see https://mbed.com/daplink Unique ID: 0418000003e8434300000000000000000000000097969904 HIC ID: 97969904 Auto Reset: 0 Automation allowed: 0 Overflow detection: 0 Daplink Mode: Interface Interface Version: 0243 Git SHA: 84e30530b3e4f1e372f525dedd86a39bf49cef15 Local Mods: 1 USB Interfaces: MSD, CDC, HID Interface CRC: 0x0b13d145 Remount count: 1
posted by Jorge Perez 19 Jul 2018

Trying second bin for MAX32625PICO (max32625pico_max32620fthr.bin) from https://os.mbed.com/teams/MaximIntegrated/wiki/MAX32625PICO-Firmware-Updates

posted by ALEXANDER SEMENOV 19 Jul 2018

Hi! I tried uploading that firmware to the PICO board as suggested. It was uploaded properly, but I am still getting the same error message.

Could it be a problem with the image? Which interface version did you use? I tested with the PICO board that has version 0243, and I tried with a different DAPLink programmer I have that has version 0242.

posted by Jorge Perez 23 Jul 2018
1 week, 3 days ago.

Hi, the link https://maximintegratedsupport.force.com/support/s/article/How-can-I-restore-the-MAX32620FTHR-bootloader-when-erased-accidently is dead, can anyone point me to the solution of this problem? I would like to restore the bootloader of the MAX32620FTHR board. Kind regards, Hans

Thank you very much, but it doesn't work in Arduino IDE because of missing configuration parameter for bootloader.tool Does anybody know how to fix the problem in Arduino IDE?

Edit

Answer: Choosing MAX32620FTHR(Programming Port) instead of MAX32620FTHR worked!

posted by Hans Schneider 13 Sep 2018

Hi Hans,

I recommend you to take a look at the Maxim Integrated Knowledge Base page for most up to date FAQs.

Here is the updated link for the question How can I restore the MAX32620FTHR bootloader (when erased accidently) ?

Feel free to create a Technical Support Case if you have further questions about Maxim Integrated Microcontrollers.

posted by Felipe Neira 13 Sep 2018

To post an answer, please log in.