1 year, 3 months ago.

Error on compiling the mbed-os-example-lorawan app - Compiler Error L6200E - Compiler Error 0

Good day,

I have imported the app into my mbed compiler (Online), but when I try to compile and download it, it throws two errors (and many warnings). I haven't been able to find the mistake.

The description of the erros are: Error: Symbol user_perthread_libspace multiply defined (by /build/mbed-os.lib/rtos/TARGET_CORTEX/rtx5/RTX/Source/rtx_lib.DISCO_L072CZ_LRWAN1.o and /build/mbed-os.lib/rtos/TARGET_CORTEX/mbed_boot.DISCO_L072CZ_LRWAN1.o). Error L6200E.

Error: Not enough information to list the image map. Error 0.

For the first error I realized that the project has two portions of code identical in different files, but those files are .o files and I don't know where to find them in the project path.

I have no idea about the second error.

P.S: I haven't made any kind of changes in the code, it's just as I imported it.

Thank you so much for your help.

Best Regards, Santiago Gil./media/uploads/sagilar/capture.png

Comment on this question

1 Answer

1 year, 3 months ago.

Hello Santiago,

There is a github issue that has been raised:

https://github.com/ARMmbed/mbed-os/issues/7422

It seems like Jerome has a found a solution that may work for you. Under the Compile button, navigate to Compile Macros and add _RTE_ in the text box. Then try recompiling. Hope that helps!

-Karen, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Thank you for your help.

The solution was to add the _RTE_ macro into the compiler.

BR.

posted by Santiago Gil 06 Jul 2018

I had the same error with the DISCO-F746NG and this solution worked for me also.

posted by Peter Ampt 17 Jul 2018