Report
7 months, 1 week ago.

Windows 10 can't connect to lpc1768

I've recently bought a new pc and I ran into a problem.

I cannot connect to the serial port of my mbed lpc1768. I had to install the mbed drivers because otherwise no serial comport was shown in device manager. After installing the drivers, the comport shows up.

Now when I try to open a connection on that port, that terminal freezes and after 30 seconds or so, a timeout error is generated. During that time, I also cannot access the storage to upload. (uploading works fine as long as I don't try to connect to the serial port).

I can connect to my nucleo and arduino boards without any problems and the lpc1768 also gives no problems on my laptop.

I'm using an Asus crosshair VI extreme mobo.

Does anybody know a way to fix this?

Hi Sander,

Are you trying to flash a program to your LPC1768 while a connection to its COM port is open?

- Jenny, team Mbed

posted by Jenny Plunkett 13 Jun 2018

Hey Jenny! No, the flashing works fine. It's the Serial connection that just isn't working at all with the LPC1768. It works fine with other boards, just not that one.

posted by Sander Swart 14 Jun 2018
Comment on this question

2 Answers

7 months, 1 week ago.

Hi again Sander,

I would try updating the firmware on your LPC1768 and also uninstalling/re-installing the Mbed serial drivers on your computer. Here's some instructions on how to do that:

Please let me know how that goes!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hi Jenny,

I tried both a couple of times already without any luck. I did just manage to solve it though. I used one of the top most usb ports on the mobo. That seems to work so far. No clue why but it might be a conflicting driver that works on all the other usb ports. Thanks for the help and if you want more information about this issue in order to get the root cause, feel free to ask!

posted by Sander Swart 14 Jun 2018
4 weeks, 1 day ago.

In case anyone else is having the same problem, I can confirm that trying different USB ports will probably fix it.

My motherboard is an Asus Prime X370 Pro with a Ryzen CPU. If I connect the LPC1768 to one of the USB ports on the back of the motherboard, the serial connection works fine.

If I connect it to one of the USB ports on the front of my machine - which are connected via a flying lead to the "USB1-2" dual row pin connector on the edge of the motherboard - the serial connection won't work. This is the case with both USB2 (black) and USB3 (blue) ports. The symptoms are the same as Sander reports: the terminal software (I'm using CoolTerm) locks up for about 30s and then reports an error.

Note that in both cases the LPC1768 appears as a disk drive and can be programmed by dropping files onto its File Explorer window as normal.

In summary:

1/ File transfers work fine no matter which USB port I plug the LPC1768 into.

2/ Serial comms only work when the LPC1768 is plugged into a USB port on the back of the motherboard.

Running Windows 10 Home and all drivers updated.


To post an answer, please log in.