Report
2 months ago.

OS v.5.4.7 for xDOT AT-command project

Hello, I'm looking for OS v.5.4.7 for current Multitech's xDOT AT-command project or updated xDOT AT-command project that works with current OS v.5.8.6. Can anybody help? Thanks, Alex

Comment on this question

1 Answer

1 month, 4 weeks ago.

Hi Alex,

You can import the Mbed OS library at version 5.4.7 into your program in the online compiler by following the steps below:

  1. Delete the existing "mbed-os" or "mbed" library in your program by right clicking on it and selecting "Delete..."
  2. Right click on your program's name and hover over "Import Library…" then select "From URL …"
  3. Import the Mbed OS library version 5.4.7 by copying and pasting the following URL: https://github.com/ARMmbed/mbed-os/commit/fc1836545dcc2fc86f03b01292b62bf2089f67c3
  4. Then click the "Import" button

This should successfully import the Mbed OS 5.4.7 library into your program.

I found the URL for the 5.4.7 Mbed OS release by looking under the “Releases” tab on the Mbed OS GitHub repository here: https://github.com/ARMmbed/mbed-os/releases/tag/mbed-os-5.4.7

Please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hi Jenny,

I tried importing version 5.4.7 of Mbed OS using the URL you posted, but it still imported the latest version of the mbed-os library.

When clicking the revision button in the online IDE, it only includes commits dating back 12 months, but version 5.4.7 dates back further than that. Is there anyway to allow more revisions to be displayed here? Doing so could allow us to switch to mbed-os versin 5.4.7.

Thanks, Lance

posted by Lance Pitka 06 Jul 2018

To post an answer, please log in.