Report
1 year, 3 months ago.

Compile mbed using ubuntu 18.04

Hi,

I'm recently update my laptop to ubuntu 18.04, but after that can't compile projects using GCC_ARM (latest arm-none-eabi). Someone has the same problem?

Thank you

Comment on this question

1 Answer

1 year, 3 months ago.

Hi Santiago,

Can you please reply with the error output and information regarding your GCC_ARM_PATH in the Mbed CLI config and their version information? (i.e. arm-none-eabi version and Mbed CLI version)

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hi Jenny,

mbed version: 1.5.1 arm-none-eabi version : 6.3.1 20170620

error output when i tray to compile: /usr/lib/gcc/arm-none-eabi/6.3.1/../../../arm-none-eabi/bin/ld: error: /usr/lib/gcc/arm-none-eabi/6.3.1/../../../arm-none-eabi/lib/crt0.o: Conflicting CPU architectures 13/1 /usr/lib/gcc/arm-none-eabi/6.3.1/../../../arm-none-eabi/bin/ld: failed to merge target specific data of file /usr/lib/gcc/arm-none-eabi/6.3.1/../../../arm-none-eabi/lib/crt0.o

Thank you in advance!

posted by Santiago Silva 14 May 2018

Hi Jenny I could resolve the problem, I had the GCC_ARM_PATH pointing to another path. Thank you!

posted by Santiago Silva 14 May 2018

Glad you were able to figure it out! :)

- Jenny, team Mbed

posted by Jenny Plunkett 14 May 2018

Which value are using for GCC_ARM_PATH? I am currently using /usr/bin and I am getting the exact same error.

posted by Mat Tau 22 Sep 2018