4 years, 5 months ago.

The interface firmware FAILED to reset/halt the target MCU Error in FRDM K64F board

Hi, I am trying to program a FRDM K64F board using another FRDM K64F board. I followed this link and achieved it. http://mcuoneclipse.com/2013/04/21/using-the-freedom-board-as-jtag-programmer/

I was able to program my target board till recently it got into bootloader mode. The reason for entering into bootloader mode is still unknown but after upgrading the firmware v0221, it started displaying Mbed. Now, when I am using FRDM board as JTAG Programmer for another FRDM K64F board, it fails every time. A fail.txt file is seen in Mbed directory which says "The interface firmware FAILED to reset/halt the target MCU". Investigating on Oscilloscope, I found that JTAG_RST pin on JTAG Connector (pin 10) goes into high impedance state immediately when I copy code to Mbed. (I used helloword_K64f.bin) when I tried separately, both boards were programmed and were executing the code. I again tried using FRDM as JTAG Programmer but failed again with same error. Can anyone guide on this? Thanks in advance

Comment on this question

2 Answers

2 years ago.

[Solved] i faced the same issue on Discovery board STM32L476G. jumper 3 was connected. (RESET). just removed jumper, updated firmware. issue solved.

1 year, 1 month ago.

I'm having trouble, can anyone help me, I'm not connecting my stm32f746-g to the stm32-st link utility of this error message: The interface firmware FAILED to reset / halt the MCU target. I tried several things and I can not connect, I wanted to erase the memory, can anyone help me?/media/uploads/atonio/f.png


You need to log in to post a question