1 year, 7 months ago.

LPCXpresso1549 flashed with wrong USB firmware

Due to my less care and the confusing online documentation together I have flashed my development board with a wrong firmware. mBed drive appears as LPC54114.

Here are my steps:

1. Programmed the LPC4322 on the development board using LPCScrypt ( LPCScrypt_installer_1.8.2_723) and firmware lpc4322_bl_crc.bin

2. Due the above flash, I have now mBed driver appears as MAINTENANCE on my Windows 7 PC.

3. I have then drag&drop the second firmware as it is suggested on the online instructions. https://os.mbed.com/teams/NXP/wiki/Updating-LPCXpresso-firmware

So, driver name now appears as LPC54114

4. But, the firmware I used there was different one :( The firmware I flashed was lpc4322_lpc54114xpresso_if_crc.bin.

But, I believe I should have flashed it with lpc4322_lpc1549_if_mbed_v0221_20150714.bin.

5. In order to fix this issue, I have then dropped the correct file lpc4322_lpc1549_if_mbed_v0221_20150714.bin But, that didn't work I believe. the driver name on the PC is still the same and inside the driver there is now another file called FAIL.txt. Inside that file says "The transfer timed out."

Is there a way to recover this mistake?

Thank you.

Comment on this question

1 Answer

1 year, 7 months ago.

You can follow the instruction from #1 to #4 in here again.

Thank you for your answer.

I know that link which was also mentioned in my question. But it didn't work as it is explained there for the situation where you flashed yours with wrong firmware. Fortunately, 5 minutes ago before you posted I figured out how to place the correct firmware.

On the link, at step #4, don't drag and drop your correct firmware but again use that the command line with DFU jumper: program_CMSIS.cmd lpc4322_lpc1549_if_mbed_v0221_20150714.bin

So, I am back in business, happy!

posted by Sener Yazman 18 Mar 2018

There is one downside of the solution I followed. It looses mBed Port (COM & LTP). Because of this reason, you can't see it in Emulator window when you want to Debug on LPCXpress IDE. So, problem is half way solved, it is not 100%. Any input greatly appreciated.

posted by Sener Yazman 18 Mar 2018

You need to log in to post a question