4 years, 7 months ago.

Windows Serial Port Driver Install Problem

I am trying to install the windows serial port driver and have run into problems.

reference:: https://developer.mbed.org/handbook/Windows-serial-configuration

Instructions are simple and went fine earlier this week on my desktop computer. However, I need to get this installed on a notebook PC. I've tried many times and get the same error: “mbedWinSerial_16466.exe is not a valid Win32 application”.

- All explorer windows are closed when I try to run this.

- Downloaded over a dozen times trying explorer, chrome and firefox. Some of the downloads appear corrupt since the file lengths differ. However, I did a binary compare on 6 copies. 3 passed a byte-byte binary compare w/size = 86,114 bytes.

- I have tried 2 different FRDM-K64F boards.

I circled back and tried running the installer on my desktop PC - the one I have been using all week without any problem. The installer doesn't run on that PC either - same error message. Unfortunately, I don't have the original download I used last week during that successful install, although I don't know if it has changed since then.

I am running a training next week in Asia which I have based on mbed. I hope someone has some advice. I'm in panic mode. Hopefully, I'm doing something dumb . . that's always an easy fix.

1 Answer

4 years, 7 months ago.

I think the file is corrupted on the web site.

I just downloaded it and tried to run it, but I get the same error. The file is also much smaller than the one I downloaded last year.

Accepted Answer

Thanks Andy, I think you're right. One of my colleagues at Maxim sent me an older version which ran just fine. He also believes that the file on-line is corrupt which my experience validates.

Not sure how to bring this to the mbed administrators attention ???

posted by Dave Sackett 02 May 2015

Use wget to grab the file. It'll fail a few times, but it'll automatically retry. My download failed 6 times with the connection dropping early, but eventually I got the whole file.

Here is the log if it helps. /media/uploads/coderlane/wget_log.txt

posted by Travis Lane 02 May 2015