1 year, 9 months ago.

WebSwitch_ENC28J60 can't work at nucleo_l476rg

https://os.mbed.com/users/hudakz/code/WebSwitch_ENC28J60/file/3bd85b731cca/main.cpp/

after terminal show "Type 10.0.0.10 secret/ into your web browser and hit ENTER",use IE type " 10.0.0.10 secret/ "or " http://10.0.0.10 secret/" web browser show erro message.

1.have try with a router or connect nucleo board direct to my computer ,all fail;/media/uploads/cstyle_0x007/main.cpp

2.if set #define DHCP 1 and connect nucleo to a router ,it will show "No DHCP server found."

Comment on this question

2 Answers

1 year, 9 months ago.

Hello,

  • Try to ping from the PC's Windows command prompt to your router (e.g. ping 10.0.0.1).
  • Check the settings of your router: Is DHCP enabled? Is the IP address 10.0.0.10 available or already leased/used by another device?
  • Connect your programmed ENC28J60 module to the router.
  • Try to ping from the PC's Windows command prompt to the ENC28J60 module (e.g. ping 10.0.0.10).
  • Is the green LED at the ENC28J60 Ethernet module's connector on?
  • Does the yellow LED at the ENC28J60 Ethernet module's connector blink when you try to ping?
  • If it doesn't work try to use an Ethernet crossover cable to connect the ENC28J60 Ethernet module to the router.
  • Sorry. The instruction printed to the serial terminal isn't correct. Please try to type 10.0.0.10/secret/ into your browser and hit Enter (as indicated on the wiki page).

hi zoltan,

tks.

1.ping 10.0.0.1 is ok 2.my router dhcp is enabled,and my computer can connect to to router and the internet 3.ping my nucleo board (ping 10.0.0.10) fail 4.yes ,enc28j60 led is on,but i'm not sure what the green led means, LEDA or LEDB pin ?,i will check again 5.must we use crossover cable for this ethernet module?

posted by z z 15 Jan 2018
  • I'm referring to the two LEDs (green and yellow) built into the Ethernet connector of the ENC28J60 module.
  • Since ENC28J60 does not have Auto MDI-X capability, unless your router is equipped with such feature a crossover ethernet cable is needed.
  • Double check the wired connection between the NUCLEO board and the ENC28J60 module. Unfortunately I don't have access to a NUCLEO-L476RG board. However, I have sussefully tested the WebSwitch with a NUCLEO-F446RE board using the same pins as you tried for the NUCLEO-L476RG:

UIPEthernet  uIPEthernet(PC_3, PC_2, PB_10, PB_9); // mosi, miso, sck, cs
  • Even in case you do not power the ENC28J60 module from the NUCLEO board, make sure the GND pins are connect one to another!
posted by Zoltan Hudak 15 Jan 2018
z z
poster
1 year, 9 months ago.

thanks Zoltan Hudak ,this driver can work with nucleo_l476rg board;


Assigned to z z 1 year, 9 months ago.

This means that the question has been accepted and is being worked on.