2 years, 9 months ago.  This question has been closed. Reason: Duplicate question

[SOLVED] - Cannot program LPC4088-based custom board

EDIT: It was unclear where was the best place to post this question was, so I cross-posted to another forum. It was answered there.

We cannot program or even erase the LPC4088 micro on our custom board. The board is based on the Embedded Artists LPC4088 QuickStart Board. Based on this schematic excerpt, what might we have done wrong?

We did already try connecting a jumper wire from the RESETn node to the RTRST node.


We're using an LPC-Link 2 to attempt the erase. As pictured below, we're using the Flash Programming GUI from the latest version of MCUXpresso IDE (v10.0.2 [Build 411] [2017-07-11]). We've tried both "Mass erase" and "Erase by sector" options; and we've tried with the "Use JTAG interface" option checked and unchecked. We get errors as shown below.

We are able to program and erase the LPC4088QSB with the same debugger (LPC-Link 2) and method (flash programming GUI), using the 20-pin ribbon cable, so I'm confident the problem lies either in the connection between the debugger and the board, or on the target board itself.



Ns: MCUXpresso RedlinkMulti Driver v10.0 (Jun 22 2017 23:31:55 - crt_emu_cm_redlink.exe build 272)
Pc: (  0) Reading remote configuration
Wc(03). No cache support.
Pc: (  5) Remote configuration complete
Nc: Reconnected to existing redlink server (PID 4294967295)
Nc: Connecting to probe 2 core 0 (server PID unknown) gave 'OK'
Nc: Probe Firmware: LPC-LINK2 CMSIS-DAP V5.182 (NXP Semiconductors)
Nc: Serial Number:  I3FUF1CU
Nc: VID:PID:  1FC9:0090
Nc: USB Path: \\?\hid#vid_1fc9&pid_0090&mi_00#7&19365f6e&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Nc: connection to debug bus (DpID 0x2BA01477 AP Index[0]: 0xFFFFFFFF) <unknown wire type> failed - 'Em(04). Cannot provide power to DAP bus.'
Nc: connection failed - Em(04). Cannot provide power to DAP bus... Retrying
Nc: connection to debug bus (DpID 0x2BA01477 AP Index[0]: 0xFFFFFFFF) <unknown wire type> failed - 'Em(04). Cannot provide power to DAP bus.'
Ed:02: Failed on connect: Em(04). Cannot provide power to DAP bus.
Et: Probe(0): Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Nc:   Last stub error 0: OK
Nc:   Last sticky error: 0x0 AIndex: 0
Nc:   No debug bus (MemAp) selected
Nc:   DAP Speed test unexecuted or failed
Nc: Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Pc: (100) Target Connection Failed
Nc: error closing down debug session - Em(02). MEM-AP is not selected.

LPC-Link 2 with harness (target board not shown):


1 Answer

2 years, 8 months ago.

Closing question