5 years, 3 months ago.

How do you import code into the mbed online compiler

Hi,

I'm trying to get up and running on mbed.

When I go to import the intial example blinky application into my online compiler it just gets stuck saying "Importing...please wait."

After 5 minutes or so there is no progress. Am I doing this wrong? Or is the online compiler no longer supported?

/media/uploads/pmg9000/screen_shot_2017-10-25_at_3.42.38_pm.png

For reference, I am on Chrome 62 with no content blocking enabled.

As someone new to this setup, is it common that mbed is offline? Is there a status page? Or known good tools such as "Works on Firefox on Windows, Does not work on Chrome on Mac"?

Edit: It appears importing using the "Import into Compiler" option fails but using the IDE's builtin "Import" button succeeds. Is there a "Issues" page to submit bugs to the mbed online compiler team?

3 Answers

5 years, 3 months ago.

Thank you for reporting the problem. We have the same observation and our web team is investigating the issue.

- Mbed Support

Accepted Answer

This issue has been fixed and "Import into Compiler" functionality from the repository page is working as expected.

posted by Senthil Rangaswamy 28 Oct 2017
5 years ago.

Hello, I'm experiencing the same issue: "Importing" message hangs. Has the "fix" been tested on the latest online compile?

5 years, 3 months ago.

Hi Paul, I am going through the same issue today. I started playing with a STM32 module yesterday and the "import into compiler" option worked correctly. I think that might be a problem related to the mbed compiler. Hope it can be worked out soon. If you have further information, please let me know