2 years, 1 month ago.

max number of ST-Link downlods to stm32f401re

What is the max ST-Link downloads to stm32f401re? before failure and not detectable anymore ? (I'm in this situation now- extensive prototyping) - It is working fine on a fresh board - no change in jumper settings.

Comment on this question

2 Answers

2 years, 1 month ago.

There is a theoretical/practical limit on the number of times you can reflash the target before the flash memory breaks down. However that is a very high number and probably not the cause of your problems. In case you dont even see the serial port and the removable memory created by the STLink you should start by checking the USB cable and/or USB socket for damage. The STLink F103 and/or the target F401 could also have been damaged in some other way (eg static discharge or overvoltage). That will be hard to fix and means replacing the device. In case you get the STLink serial and memory going again but still fail to reprogram the target it may help to reflash the STLInk firmware as shown on the F401 nucleo page.

2 years, 1 month ago.

No limit on the board. Be sure to wipe your downloads directory clean wherever you are putting the files from mbed before going to the board. There is a count issue once you hit a certain number of files on disk. That is solved by clearing the directory in my experience.

Thank you Bill, actually I download the bin file from mbed to the board directly. I do not store the downloads on PC disk. Currently no serial port is available on my system while the USB STlink is connected but the board is powered.

posted by kaled saleh 23 Sep 2017

My experience has been mixed with storing directly to the board so I began saving to hard disk first then transferring. That has been reliable. The fact that you can't see the serial indicates as Wim says that there is a board problem. I personally would move on to a new board considering the price! :)

posted by Bill Bellis 23 Sep 2017