3 years, 10 months ago.

How to disable mbed-coap trace or reduce its level?

I have enabled tracing in mbed_app.json:

    "target_overrides": {
        "*": {
            "target.features_add": ["LWIP", "COMMON_PAL"],
            "lwip.ipv4-enabled": true,
            "lwip.ethernet-enabled": false,
            "lwip.ppp-enabled": true,
            "lwip.tcp-enabled": true,
            "platform.stdio-convert-newlines": true,
            "platform.stdio-baud-rate": 115200,
            "platform.default-serial-baud-rate": 115200,
            "mbed-trace.enable": 1
        },

and then I tried to turn of tracing in mbed-coap module:

        "mbed-coap": {
            "mbed-trace.enable": false
        }

However, I still see log messages from mbed-coap.

Be the first to answer this question.